3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/libtgvoip-disable-webrtc.patch
Brett Gilio 1792a70655
gnu: libtgvoip: Fix failing build on i686-linux.
* gnu/local.mk (libtgvoip): Add patches for libtgvoip-disable-sse2.patch
and libtgvoip-disable-webrtc.patch

* gnu/packages/patches/libtgvoip-disable-sse2.patch: New file.

* gnu/packages/patches/libtgvoip-disable-webrtc.patch: New file.

* gnu/packages/telephony.scm (libtgvoip): Fix building on i686-linux.
[source]: Reference patches for correcting failing build on i686-linux
architecture.

Reported-by: Diego Nicola Barbato <dnbarbato@posteo.de>
Fixes <bugs.gnu.org/38944>.
2020-01-05 19:31:07 -06:00

48 lines
1.4 KiB
Diff

Copied from Debian.
Description: Fix build of WebRTC on non-Linux systems
* Define the WEBRTC_LINUX macro only on Linux, and not on GNU/Hurd or FreeBSD.
* Fix type cast in the CurrentThreadId function.
Bug-Debian: https://bugs.debian.org/920851
Author: Nicholas Guriev <guriev-ns@ya.ru>
Last-Update: Tue, 29 Jan 2019 23:26:44 +0300
--- a/libtgvoip.gyp
+++ b/libtgvoip.gyp
@@ -869,20 +869,18 @@
'"<(OS)" == "linux"', {
'defines': [
'WEBRTC_POSIX',
- 'WEBRTC_LINUX',
],
'conditions': [
[ '"<!(uname -m)" == "i686"', {
'cflags_cc': [
'-msse2',
],
+ }], ['"<!(uname -s)" == "Linux"', {
+ 'defines': [
+ 'WEBRTC_LINUX',
+ ],
}]
],
- 'direct_dependent_settings': {
- 'libraries': [
-
- ],
- },
},
],
],
--- a/webrtc_dsp/rtc_base/platform_thread_types.cc
+++ b/webrtc_dsp/rtc_base/platform_thread_types.cc
@@ -31,7 +31,7 @@ PlatformThreadId CurrentThreadId() {
return syscall(__NR_gettid);
#else
// Default implementation for nacl and solaris.
- return reinterpret_cast<pid_t>(pthread_self());
+ return static_cast<pid_t>(pthread_self());
#endif
#endif // defined(WEBRTC_POSIX)
}