3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/perl-deterministic-ordering.patch
Marius Bakke f94a8654d6
gnu: perl: Update to 5.28.0.
* gnu/packages/patches/perl-deterministic-ordering.patch: Adjust path.
* gnu/packages/patches/perl-archive-tar-CVE-2018-12015.patch,
gnu/packages/patches/perl-file-path-CVE-2017-6512.patch: Delete files.
* gnu/local.mk (dist_patch_DATA): Remove them.
* gnu/packages/perl.scm (perl): Update to 5.28.0.
[source](patches): Remove obsolete.
2018-07-21 02:12:33 +02:00

30 lines
886 B
Diff

From <https://bugs.debian.org/801523>.
From c01f602d1926b0671fd2c8d91f7e52c4e4c9fb24 Mon Sep 17 00:00:00 2001
From: Niko Tyni <ntyni@debian.org>
Date: Sun, 11 Oct 2015 19:27:56 +0300
Subject: [PATCH] Sort the list of XS code files when generating RealPPPort.xs
all_files_in_dir() uses readdir() ordering to make the list of
input files. This can vary between build systems, breaking build
reproducibility.
---
cpan/Devel-PPPort/PPPort_xs.PL | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/dist/Devel-PPPort/PPPort_xs.PL b/dist/Devel-PPPort/PPPort_xs.PL
index 5f18940..149f2fe 100644
--- a/dist/Devel-PPPort/PPPort_xs.PL
+++ b/dist/Devel-PPPort/PPPort_xs.PL
@@ -38,7 +38,7 @@ END
my $file;
my $sec;
-for $file (all_files_in_dir('parts/inc')) {
+for $file (sort(all_files_in_dir('parts/inc'))) {
my $spec = parse_partspec($file);
my $msg = 0;
--
2.5.1