3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/perl-www-curl-fix-struct-void.patch
Tobias Geerinckx-Rice 2c560aa217
gnu: perl-www-curl: Fix build with curl@7.69.1.
* gnu/packages/web.scm (perl-www-curl)[source]:
Add perl-www-curl-fix-struct-void.patch.
* gnu/packages/patches/perl-www-curl-remove-symbol.patch: Update.
* gnu/packages/patches/perl-www-curl-fix-struct-void.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
2020-11-15 00:12:11 +01:00

25 lines
717 B
Diff
Raw Blame History

This file contains ambiguous Unicode characters

This file contains Unicode characters that might be confused with other characters. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Sat, 14 Nov 2020 15:40:56 +0100
Subject: [PATCH] gnu: perl-www-curl: Fix struct void* usage.
Copied verbatim from Gentoo[0]. Fixes:
Curl.xs:76:12: error: expected { before void
struct void *curlm;
^~~~
Curl.xs:76:12: error: two or more data types in declaration specifiers
[0]: https://694466.bugs.gentoo.org/attachment.cgi?id=595098
--- WWW-Curl-4.17/Curl.xs 2014-02-21 18:08:30.000000000 +0200
+++ WWW-Curl-4.17.new/Curl.xs 2019-11-05 21:44:55.434395739 +0200
@@ -73,7 +73,7 @@ typedef struct {
#ifdef __CURL_MULTI_H
struct CURLM *curlm;
#else
- struct void *curlm;
+ void *curlm;
#endif
} perl_curl_multi;