3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/python-paste-remove-timing-test.patch
Christopher Allan Webber c4a7904c21 gnu: Add python-paste.
* gnu/packages/python.scm (python-paste, python2-paste): New variables.
* gnu/packages/patches/python-paste-remove-timing-test.patch: New file.
* gnu/packages/patches/python-paste-remove-website-test.patch: New file.
* gnu-system.am (dist_patch_DATA): Add them.
2016-02-25 11:01:45 -08:00

17 lines
775 B
Diff

Remove this test to verify that things were modified since a certain time.
That assumption doesn't hold up when your environment doesn't have access to a
real clock and thinks it's living in 1970 :)
--- a/tests/test_fileapp.py 2015-04-23 13:48:37.000000000 -0700
+++ b/tests/test_fileapp.py 2016-02-22 19:20:08.332802417 -0800
@@ -223,8 +223,6 @@
status=304)
res = app.get('/', headers={'If-None-Match': 'asdf'},
status=200)
- res = app.get('/', headers={'If-Modified-Since': 'Sat, 1 Jan 2005 12:00:00 GMT'},
- status=200)
res = app.get('/', headers={'If-Modified-Since': last_mod + '; length=100'},
status=304)
res = app.get('/', headers={'If-Modified-Since': 'invalid date'},