3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/xmonad-dynamic-linking.patch
Timothy Sample 57983029a9
gnu: xmonad: Add patch to support dynamic linking.
Fixes <https://bugs.gnu.org/43131>.

* gnu/packages/patches/xmonad-dynamic-linking.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/wm.scm (xmonad)[source]: Use it.
2020-09-02 18:09:01 -04:00

17 lines
724 B
Diff

This patch is required for xmonad to make use of shared libraries.
Without it, xmonad will not work since we do not (by default) use
statically linked Haskell libraries.
diff -ruN xmonad-0.15-a/src/XMonad/Core.hs xmonad-0.15-b/src/XMonad/Core.hs
--- xmonad-0.15-a/src/XMonad/Core.hs 1969-12-31 19:00:00.000000000 -0500
+++ xmonad-0.15-b/src/XMonad/Core.hs 1969-12-31 19:00:00.000000000 -0500
@@ -681,6 +681,8 @@
compileGHC bin dir errHandle =
runProcess "ghc" ["--make"
, "xmonad.hs"
+ , "-dynamic"
+ , "-fPIC"
, "-i"
, "-ilib"
, "-fforce-recomp"