3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/combinatorial-blas-io-fix.patch
Eric Bavier a6b9ebc2fc
gnu: Add Combinatorial BLAS.
* gnu/packages/maths.scm (combinatorial-blas): New variable.
* gnu/packages/patches/combinatorial-blas-awpm.patch,
gnu/packages/patches/combinatorial-blas-io-fix.patch: New files
* gnu/local.mk(dist_patch_DATA): Add them.
2019-01-25 13:09:47 -06:00

15 lines
486 B
Diff

IO not appropriate in the context of a sorting routine, and in any case the
proper headers are not included, so gcc emits an undefined symbol error.
Remove the "printf" statement.
--- CombBLAS_beta_16_2/usort/include/usort/seqUtils.tcc
+++ CombBLAS_beta_16_2/usort/include/usort/seqUtils.tcc
@@ -142,7 +142,6 @@
}
if ( (a[nmax]==a[nmin]) && (ctr==0) )
{
- printf("All the numbers are identical, the list is sorted\n");
return;
}