3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/gash-utils-ls-test.patch
Ludovic Courtès af74c0633a
gnu: gash, gash-utils: Build with Guile 3.0.
* gnu/packages/shells.scm (gash)[source]: Add 'modules' and 'snippet'.
[inputs]: Change GUILE-2.2 to GUILE-3.0.
(gash-utils)[source]: Add 'modules' and 'snippet'.
[inputs]: Change GUILE-2.2 to GUILE-3.0.
* gnu/packages/commencement.scm (gash-utils-boot)[source]: Remove
unneeded 'modules' field, and add 'snippet'.
(gash-utils-boot)[source]: New field.
* gnu/packages/patches/gash-utils-ls-test.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
2020-07-02 23:54:02 +02:00

26 lines
628 B
Diff

'ls.scm' monkey-patches (ice-9 getopt-long) to allow it to recognize '-1'
as a valid option. Unfortunately, monkey patching no longer works with
Guile 3.0 due to inlining, so change the test to make do without '-1'.
diff --git a/tests/core-utils.org b/tests/core-utils.org
index d35ede8..22718e3 100644
--- a/tests/core-utils.org
+++ b/tests/core-utils.org
@@ -93,14 +93,11 @@
* ls
:script:
#+begin_src sh
- ls -1 tests/data/star
+ ls tests/data/star
#+end_src
:stdout:
#+begin_example
- 0
- 1
- 2
- 3
+ 0 1 2 3
#+end_example
* test-file