3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/gcc-arm-link-spec-fix.patch
Ludovic Courtès 2068559ba0 gnu: gcc: Move patch upstream status in the patch itself.
* gnu/packages/patches/gcc-arm-link-spec-fix.patch: Add bug and patch URLs.
* gnu/packages/gcc.scm (gcc-4.8): Remove them.
2015-06-04 09:30:20 +02:00

21 lines
742 B
Diff

Do not pass -dynamic-linker to linker when !shared.
Fixes <http://bugs.gnu.org/20102>.
ARM 'link' spec issue reported at
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=65711 and
https://gcc.gnu.org/ml/gcc-patches/2015-04/msg01387.html.
Patch by Ludovic Courtès <ludo@gnu.org>.
--- gcc-4.8.4/gcc/config/arm/linux-elf.h.orig 2015-04-08 20:31:20.376900478 +0200
+++ gcc-4.8.4/gcc/config/arm/linux-elf.h 2015-04-08 20:31:36.437014437 +0200
@@ -65,7 +65,7 @@
%{symbolic:-Bsymbolic} \
%{!static: \
%{rdynamic:-export-dynamic} \
- -dynamic-linker " GNU_USER_DYNAMIC_LINKER "} \
+ %{!shared:-dynamic-linker " GNU_USER_DYNAMIC_LINKER "}} \
-X \
%{mbig-endian:-EB} %{mlittle-endian:-EL}" \
SUBTARGET_EXTRA_LINK_SPEC