3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/bowtie-fix-makefile.patch
Ricardo Wurmus 241e122193 gnu: bowtie: fix build errors
* gnu/packages/bioinformatics.scm (bowtie): Add 'supported-systems' field and
  add Makefile patch.
* gnu/packages/patches/bowtie-fix-makefile.patch: New file.
* gnu-system.am (dist_patch_DATA): Add it.
2015-01-30 10:45:27 +01:00

32 lines
767 B
Diff

From 4a99b0023bdfbbe486b9649489a32ea184c18c9a Mon Sep 17 00:00:00 2001
From: Valentin Antonescu <valentin@jhu.edu>
Date: Tue, 2 Dec 2014 11:19:13 -0500
Subject: [PATCH] Make sure the Mavericks test happens only under Darwin.
---
Makefile | 11 +++++------
1 file changed, 5 insertions(+), 6 deletions(-)
diff --git a/Makefile b/Makefile
index d74f7c8..a4cdfa7 100644
--- a/Makefile
+++ b/Makefile
@@ -54,12 +54,11 @@ endif
MACOS = 0
ifneq (,$(findstring Darwin,$(shell uname)))
MACOS = 1
-endif
-
-ifneq (,$(findstring 13,$(shell uname -r)))
- CPP = clang++
- CC = clang
- EXTRA_FLAGS += -stdlib=libstdc++
+ ifneq (,$(findstring 13,$(shell uname -r)))
+ CPP = clang++
+ CC = clang
+ EXTRA_FLAGS += -stdlib=libstdc++
+ endif
endif
POPCNT_CAPABILITY ?= 1