jobcomm/agetpkg/PKGBUILD

39 lines
1000 B
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcomm/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=agetpkg
pkgver=4.r0.g673e371
pkgrel=02
pkgdesc='Archlinux Archive Get Package (Git version)'
url='https://github.com/seblu/agetpkg'
makedepends=('git')
conflicts=('agetpkg-git')
provides=('agetpkg')
source=("${pkgname}::git+${url}.git")
pkgver() {
cd "$srcdir/$pkgname"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
package() {
cd "$srcdir/$pkgname"
depends=('python' 'python-xdg')
install -Dm755 agetpkg "$pkgdir/usr/bin/agetpkg"
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=('GPL2')
sha256sums=('SKIP')
## 2967c246f04a1ea185194553889f51418ff2302dbfdaec6a8de71932b4bd176a agetpkg-4.r0.g673e371-02-x86_64.pkg.tar.lz