jobcomm/evdi/PKGBUILD

43 lines
1.3 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcomm/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=evdi
pkgver=1.14.2
pkgrel=01
pkgdesc="A Linux® kernel module that enables management of multiple screens."
url="https://github.com/DisplayLink/evdi"
depends=(glibc dkms libdrm) # linux-headers)
changelog=$pkgname.Changelog
source=(https://github.com/DisplayLink/evdi/archive/v$pkgver/$pkgname-$pkgver.tar.gz)
build() {
# We only need to build the library in this step, dkms will build the module
cd "$pkgname-$pkgver/library"
make
}
package() {
cd "$pkgname-$pkgver"
install -Dm0755 library/lib$pkgname.so "$pkgdir/usr/lib/lib$pkgname.so"
SRCDIR="$pkgdir/usr/src/$pkgname-$pkgver" # This one is needed for dkms
install -d "$SRCDIR"
install -Dm0755 module/* "$SRCDIR"
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=('GPL')
sha256sums=(5d14635bdf41ae594018e061032090f6752293b05b365b0324afb9401b340ac5) # evdi-1.14.2.tar.gz
## 8ea1338501a6b9619355260baf3e4f9641428817911cf0ab86e1743392c1c91a evdi-1.14.2-01-x86_64.pkg.tar.lz