jobcomm/gns3-server/PKGBUILD

80 lines
2.7 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcomm/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=gns3-server
pkgver=2.2.46
pkgrel=02
pkgdesc='GNS3 network simulator, Server w/o systemd'
url='https://github.com/GNS3/gns3-server'
groups=('gns3')
depends=(
'busybox'
'python-aiofiles'
'python-aiohttp'
'python-aiohttp-cors'
'python-async-timeout'
'python-distro'
'python-jinja'
'python-jsonschema'
'python-platformdirs'
'python-psutil'
'python-py-cpuinfo'
'python-sentry_sdk'
'python-setuptools'
'python-truststore'
)
optdepends=(
'dynamips: Cisco router emulator'
'gns3-gui: graphical user interface for GNS3 server'
'qemu: Used by GNS3 to run Cisco ASA, PIX and IDS'
'libvirt: needed for the NAT cloud'
'vpcs: Simple PC emulation for basic network operations'
'ubridge: Bridge for UDP tunnels, Ethernet, TAP and VMnet interfaces'
)
# install="$pkgname".install ## systemd crap left here for reference
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
"fix_requirements_for_Arch.diff"
"$pkgname@.service"
"gns3.service.openrc")
prepare() {
cd "$pkgname-$pkgver"
# Arch usually has the latest versions. Patch requirements to allow them.
patch --strip=2 -i "$srcdir"/fix_requirements_for_Arch.diff
}
build() {
cd "$pkgname-$pkgver"
python setup.py build
}
package() {
cd "$pkgname-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
## see $srcdif/init for current service files
## TODO:
## use the following to make a script or a runit/66 service
## if and when you do, either runit or 66 or both, feel free to share
install -Dm644 "$srcdir/$pkgname@.service" "$pkgdir/usr/share/docs/$pkgname/$pkgname@.service"
install -Dm644 "$srcdir/gns3.service.openrc" "$pkgdir/usr/share/docs/$pkgname/gns3.service.openrc"
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=('GPL3')
sha256sums=(648f535370827adc8ede2e5a8f439161dd80c66c11ed74085ccf0b71657ee9f9 # gns3-server-2.2.46.1.tar.gz
68aa2049ca756b32702699ff4be33090c3e56e38e79b3202c762dbafddb4309b # fix_requirements_for_Arch.diff
b43f0ead963a06e613d3303d2c66372b57f46c750b3d6df20eb99c11078de65f # gns3-server.service
928eda53c688cd1aa22298d7e317fda7546930c9964dff84a7c2d4b865a2a6a3) # gns3.service.openrc
## 68948dbbefea5ec747c4fbe750a3774fb6a0496537ee87b350fe4409eb6f6ba0 gns3-server-2.2.46-02-x86_64.pkg.tar.lz