jobcomm/litemdview/PKGBUILD

42 lines
1.2 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcomm/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=litemdview
pkgver=0.0.32
pkgrel=03
pkgdesc="Suckless markdown and html viewer - simply unbelievable"
url="https://codeberg.org/g0tsu/litemdview"
depends=('gtkmm3')
makedepends=('fontconfig')
source=($url/archive/$pkgname-$pkgver.tar.gz
$pkgname.desktop)
build() {
cd $pkgname
./bootstrap
./configure --prefix=/usr
make
}
package() {
cd $pkgname
make DESTDIR="$pkgdir" install
install -Dm644 "$srcdir"/$pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=('GPL2')
sha256sums=(d0f1d3e12ccfec7919dfb0d589e5d2cbea04b17231cbbe35f6b71451423f044f # litemdview-0.0.32.tar.gz
3e9e00dcf4165a1dc6dcea7a73881d3a6e2bf578f455cee3209e3cb0e81b3437) # litemdview.desktop
## a2e8ab78b3c251eca81e81bbc4c537e5f634e6356ed51fcfa10ac2fbf3ad23ce litemdview-0.0.32-03-x86_64.pkg.tar.lz