jobcomm/modprobed-db/PKGBUILD

39 lines
1.1 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcomm/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=modprobed-db
pkgver=2.46
pkgrel=02
pkgdesc='Keeps track of EVERY kernel module ever used - useful for make localmodconfig w/o systemd'
arch=('any')
depends=('kmod')
optdepends=('sudo: needed for recall function')
replaces=('modprobed_db')
conflicts=('modprobed_db')
url="https://wiki.archlinux.org/index.php/Modprobed-db"
source=("$pkgname-$pkgver.tar.gz::https://github.com/graysky2/$pkgname/archive/v$pkgver.tar.gz")
install=readme.install
build() {
cd "$pkgname-$pkgver"
make
}
package() {
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
install -Dm644 MIT "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
rm -rf $pkgdir/usr/lib
}
#---- license gpg-key sha256sums ----
license=('MIT')
sha256sums=(34a0cd3fa67efea8a2ba657d90ce2f5e3ef480babb7f3bcae6c13bac1eb4eeab) # modprobed-db-2.46.tar.gz