jobcomm/novelwriter/PKGBUILD

45 lines
1.7 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcomm/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgbase='novelwriter'
pkgname=('novelwriter')
_module='novelWriter'
pkgver=2.2
pkgrel=02
pkgdesc="A markdown-like document editor for writing novels"
url="https://novelwriter.io"
depends=('python' 'python-pyenchant' 'python-lxml' 'python-pyqt5' 'python-pyqt5-webengine' 'qt5-svg' 'nuspell')
makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel')
source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
build() {
cd "${srcdir}/${_module}-${pkgver}"
python -m build --wheel --no-isolation
}
package() {
depends+=()
cd "${srcdir}/${_module}-${pkgver}"
python -m installer --destdir="$pkgdir" dist/$_module-$pkgver-py3-none-any.whl
install -D setup/data/novelwriter.desktop -t "${pkgdir}"/usr/share/applications
install -D setup/data/novelwriter.png -t "${pkgdir}"/usr/share/pixmaps
install -D setup/data/x-novelwriter-project.xml -t "${pkgdir}"/usr/share/mime/packages
mkdir -p "${pkgdir}"/usr/share/icons/"${pkgname}" && cp -r setup/data/hicolor/* "${pkgdir}"/usr/share/icons/"${pkgname}"
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=('GPL')
sha256sums=(b231bad288433950119df16a6aae95eede2484d6345a40c70b7df8e29d4467c0) # novelWriter-2.2.tar.gz
## 5af0860cf0a83c307c71c4ae78377718ac3de054182e2293721810a0b7af9da1 novelwriter-2.2-02-x86_64.pkg.tar.lz