jobcomm/ntopng/PKGBUILD

56 lines
1.8 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcomm/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=ntopng
pkgver=6.0
_ndpiver=4.8
pkgrel=02
pkgdesc='The next generation version of the original ntop, a network traffic probe that shows the network usage w/o systemd'
url='http://www.ntop.org/'
depends=('redis' 'libmariadbclient' 'libpcap' 'sqlite' 'libmaxminddb' 'zeromq' 'rrdtool' 'hiredis')
makedepends=('glib2' 'automake' 'libtool' 'wget' 'curl' 'libxml2' 'npm')
source=("$pkgname-$pkgver.tar.gz::https://github.com/ntop/$pkgname/archive/$pkgver.tar.gz"
"nDPI-$_ndpiver.tar.gz::https://github.com/ntop/nDPI/archive/$_ndpiver.tar.gz"
"$pkgname.sysusers")
build() {
cd $srcdir/nDPI-$_ndpiver
./autogen.sh
./configure
make
export NDPI_HOME=$srcdir/nDPI-$_ndpiver
cd $srcdir/$pkgname-$pkgver
./autogen.sh
./configure --prefix=$pkgdir/usr --datadir=/usr/share
npm install
npm run build
make
}
package() {
cd $srcdir/$pkgname-$pkgver
make install
mv $pkgdir/usr/{man,share/}
install -Dm644 "$srcdir/$pkgname.sysusers" "$pkgdir/usr/lib/sysusers.d/$pkgname.conf"
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=('GPL3')
validpgpkeys=('EFD9413B17293AFDFE6EA6F1402A088DEDF104CB')
sha256sums=(937e3dea081f68cb8d85e0a925f5277f6a358d65ba45e90e215f0fc36d2401ac # ntopng-6.0.tar.gz
8f6235ba672d4ac8e4cbebb5611bc712a74587d9d53a649f483e4bcca5b80e58 # nDPI-4.8.tar.gz
58518c808ea300350e6aaa83fafb2320dfed85dd8615793bba3d5b6041edb1b5) # ntopng.sysusers
## e0bc9d9fd9c72c9415d7b10126bf31e5f4fec4cbbcb1ed91ca8f1bedd8f4d343 ntopng-6.0-02-x86_64.pkg.tar.lz