jobcomm/tinyramfs/PKGBUILD-4-AUR
2023-09-09 00:00:08 +03:00

54 lines
1.9 KiB
Plaintext

Maintainer : Joe Bo Run <joborun@disroot.org>
pkgname=tinyramfs
pkgver=0.1.1rc
pkgrel=1
pkgdesc="Tiny initramfs written in POSIX shell by illiliti - experimental use only not well tested on arch based systems"
url="https://github.com/illiliti/tinyramfs"
makedepends=(git)
depends=(util-linux cpio binutils kmod)
optdepends=('xz: Use xz compression for the initramfs image'
'bzip2: Use bzip2 compression for the initramfs image'
'lzop: Use lzo compression for the initramfs image'
'lz4: Use lz4 compression for the initramfs image')
provides=('initramfs')
backup=('etc/tinyramfs/config')
source=(git+https://github.com/illiliti/tinyramfs
#"$url/archive/refs/tags/$pkgver.tar.gz" # 0.1.0 without latest commits
config)
install=$pkgname.install
# patches from void that appear to have been committed in latest master
#prepare() {
# cd "${pkgname}"
# cd "${pkgname}-${pkgver}"
# patch -Np1 -i ../modinfo.patch
# patch -Np1 -i ../modprobe.patch
#}
#check() {
# make -C $pkgname check
# from void:
# make_check=no # checking requires qemu, locally this still fails
#}
package() {
cd "${pkgname}"
make DESTDIR=$pkgdir PREFIX=/usr MANDIR=/usr/share/man/$pkgname DOCDIR=/usr/share/doc/$pkgname install
install -Dm644 "${srcdir}/config" "${pkgdir}/etc/tinyramfs/config"
## rm -rf $pkgdir/usr/lib/tinyramfs/hook.d/systemd-udev
install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
install -Dm644 README.md $pkgdir/usr/share/doc/$pkgname/README.md
}
arch=(x86_64)
license=(GPL-3.0-only)
sha256sums=(SKIP # tinyramfs
#a78ecd56a52a02bc1f4b86ba829a957ad1f83c252bfde66562d5c3ef40be7c51 # 0.1.0.tar.gz
0c66f63b2fb1191293cc676bc0f3f053396343fd6f9c3e30981222cce2f4e454) # config
# 9798e5d5979f7e45a6533302eb307f20a652a565d6c5e00819d1399de0056ccb # modinfo.patch
# e3660ca4da1c82c41675fffd9b68140a8fc4d43d2af111f6983fb90521656a8d) # modprobe.patch