jobcore/base-devel/PKGBUILD

46 lines
2.3 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcore/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=base-devel
pkgver=1
pkgrel=02
pkgdesc='Basic tools to build Arch Linux packages are a few more than Joborun jobbot and not always necesary'
# instead of the pkg group base-devel Arch is now making a metapackage for their building chroot
# just like joborun has the jobbot pkg! Ha! We did this first, but our chroot is slim, not fat!
# url='https://www.archlinux.org'
url='http://pozol.eu'
# basically the dependencies of jobbot1 now, but since some people may wish to
# build software within their system, not on chroot, we replaced the jobbot dependency
# with direct dependencies of jobbot1.
depends=( acl archlinux-keyring obarun-keyring joborun-keyring attr audit bash
binutils brotli bzip2 ca-certificates ca-certificates-mozilla ca-certificates-utils
coreutils curl db diffutils e2fsprogs elfutils expat fakeroot file
filesystem findutils flex gawk gc gcc gcc-libs gdbm glib2 glibc gmp gnupg gnutls gpgme
grep groff guile gzip hwdata iana-etc icu iproute2 iptables iputils jansson json-c
keyutils kmod krb5 less libarchive libassuan libcap libcap-ng libelf libeudev libffi
libgcrypt libgpg-error libidn2 libisl libksba libldap libmnl libmpc libnetfilter_conntrack
libnfnetlink libnftnl libnghttp2 libnghttp3 libnl libp11-kit libpcap libpsl libsasl
libseccomp libsecret libssh2 libtasn1 libtirpc libtool libunistring libusb libutempter
libverto libxcrypt licenses linux-api-headers lz4 lzip m4 make mpfr nano ncurses nettle
npth numactl openssl p11-kit pacman pacman-mirrorlist pam pambase patch pciutils pcre
pcre2 perl pinentry pkgconf procps-ng psmisc readline sed shadow sqlite sudo tar texinfo
tpm2-tss tzdata util-linux util-linux-libs which xz yajl zlib zsh zstd )
install=base-devel.install
source=(base-devel.install)
#depends=('jobbot1')
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=('ISC')
sha256sums=(f6dcd6b6a10bc96dbaadee5fced55d6104602e0e19ef357320858710bfe91007) # base-devel.install
## f1cde4d17136f38a807633230b60e6a40882a774880e7345654bb98748c4dfb7 base-devel-1-02-x86_64.pkg.tar.lz