jobcore/db/PKGBUILD

52 lines
1.3 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcore/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=db
pkgver=6.2.32
pkgrel=01
pkgdesc="The Berkeley DB embedded database system"
arch=('x86_64')
arch=(x86_64)
groups=(jobbot)
url="https://www.oracle.com/technology/software/products/berkeley-db/index.html"
depends=('gcc-libs' 'sh')
source=(https://download.oracle.com/berkeley-db/db-${pkgver}.tar.gz)
#prepare() {
# cd $pkgname-$pkgver
# patch -p0 -i ../atomic.patch # Fix build
#}
build() {
cd ${pkgname}-${pkgver}/build_unix
../dist/configure \
--prefix=/usr \
--enable-compat185 \
--enable-shared \
--enable-static \
--enable-cxx \
--enable-dbm \
--enable-stl
make LIBSO_LIBS=-lpthread
}
package() {
make -C ${pkgname}-${pkgver}/build_unix DESTDIR="${pkgdir}" install
rm -r "${pkgdir}"/usr/docs
}
#---- license gpg-key sha256sums ----
license=(AGPL3)
b2sums=('d3254fba1300d6c7dda5d872c5fa349e8704d71be9c4d37ccf3357782adeb879ce30e066cf083bd97554405c2e94071a96cee16090ad9f797a4fa657ff7e8c46')
sha256sums=(a9c5e2b004a5777aa03510cfe5cd766a4a3b777713406b02809c17c8e0e7a8fb) # db-6.2.32.tar.gz