jobcore/dialog/PKGBUILD

46 lines
1.3 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcore/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=dialog
pkgver=1.3_20240307
pkgrel=02
epoch=1
pkgdesc="A tool to display dialog boxes from shell scripts"
url="https://invisible-island.net/dialog/"
depends=('sh' 'ncurses')
provides=('libdialog.so')
source=(https://invisible-mirror.net/archives/$pkgname/$pkgname-${pkgver/_/-}.tgz{,.asc})
build() {
cd "$srcdir/$pkgname-${pkgver/_/-}"
./configure \
--prefix=/usr \
--enable-nls \
--with-libtool \
--with-ncursesw
make
}
package() {
cd "$srcdir/$pkgname-${pkgver/_/-}"
make DESTDIR="$pkgdir" install-full
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=('LGPL2.1')
validpgpkeys=('19882D92DDA4C400C22C0D56CC2AF4472167BE03') # Thomas E. Dickey (self-signed w/o SHA1) <dickey@invisible-island.net>
sha256sums=(339d311c6abb240213426b99ad63565cbcb3e8641ef1989c033e945b754d34ef # dialog-1.3-20240307.tgz
31626e6ad0f1110894ad33126048a5920d7f4d2aa6e9fc0c1c9d25a6d6c1e97e) # dialog-1.3-20240307.tgz.asc
## 5c45488b43bb06e884bf583538667d512f08a228118838e2accd1c81194a5f19 dialog-1_1.3_20240307-02-x86_64.pkg.tar.lz