jobcore/file/PKGBUILD

75 lines
2.3 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcore/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=file
pkgver=5.45
pkgrel=01
pkgdesc='File type identification utility'
url='https://www.darwinsys.com/file/'
depends=('glibc' 'zlib' 'xz' 'bzip2' 'libseccomp' 'libseccomp.so')
#depends=('glibc' 'zlib' 'xz' 'bzip2' 'libseccomp' 'libseccomp.so' 'zstd' 'libzstd.so')
# what utter bullshit rebuild by Arch psychos, zstd is there anywhere pacman must be installed, so what's the point?
# and even if you use configure zstd disabled, half the source is based on zstd presence anyway. You remove zstf from any system, even build-chroot and pacman is dead.
provides=('libmagic.so')
options=('!emptydirs')
#options=('!emptydirs' 'debug') ## uncomment this to have the debug pkg produced
source=("https://astron.com/pub/$pkgname/$pkgname-$pkgver.tar.gz"{,.asc})
prepare() {
cd $pkgname-$pkgver
# apply patch from the source array (should be a pacman feature)
local src
for src in "${source[@]}"; do
src="${src%%::*}"
src="${src##*/}"
[[ $src = *.patch ]] || continue
echo "Applying patch $src..."
patch -Np1 < "../$src"
done
}
build() {
cd $pkgname-$pkgver
# Fix linking libmagic (vfork needs libpthread)
CFLAGS+=" -pthread"
./configure \
--prefix=/usr \
--datadir=/usr/share/file \
--enable-fsect-man5 \
--enable-libseccomp \
--disable-zstd
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}
check() {
cd $pkgname-$pkgver
make check
}
package() {
cd $pkgname-$pkgver
make DESTDIR="$pkgdir" install
install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=('custom')
validpgpkeys=('BE04995BA8F90ED0C0C176C471112AB16CB33B3A') # Christos Zoulas
sha256sums=(fc97f51029bb0e2c9f4e3bffefdaf678f0e039ee872b9de5c002a6d09c784d82 # file-5.45.tar.gz
34af47be1584ed99529c21a916444bbce4caf1ca289b241d8e649f7fdd9e3ec6) # file-5.45.tar.gz.asc
## 13b8f10b8f85e6d469baf224d8b3f2f8490ae395e6ba63963c6212eb1338db05 file-5.45-01-x86_64.pkg.tar.lz