jobcore/guile/PKGBUILD

59 lines
1.9 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcore/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=guile
pkgver=3.0.9
pkgrel=01
pkgdesc='Portable, embeddable Scheme implementation written in C'
url='https://www.gnu.org/software/guile/'
arch=(x86_64)
groups=( jobbot )
##--- depends=(gmp libltdl ncurses texinfo libunistring gc libffi)
depends=(gmp libxcrypt ncurses libunistring gc libffi)
makedepends=(texinfo)
source=(https://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.gz{,.sig})
#prepare() {
# cd $pkgname-$pkgver
# sed -e '/test-out-of-memory/d' -i test-suite/standalone/Makefile.am # Disable test known to fail https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=966301
# autoreconf -if
#}
build() {
cd $pkgname-$pkgver
./configure --prefix=/usr \
--disable-static \
--disable-error-on-warning
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}
### when some tests fail comment this check section out and rerun without removing src and without using the makepkg -f option
#check() {
# cd $pkgname-$pkgver
# make check
#}
###
package() {
make -C $pkgname-$pkgver DESTDIR="$pkgdir" install
rm "$pkgdir"/usr/lib/libguile-3.?.so.*-gdb.scm
}
#---- license gpg-key sha256sums ----
license=(GPL)
validpgpkeys=('3CE464558A84FDC69DB40CFB090B11993D9AEBB5' # Ludovic Courtès <ludo@gnu.org>
'FF478FB264DE32EC296725A3DDC0F5358812F8F2' # Andy Wingo
'4FD4D288D445934E0A14F9A5A8803732E4436885') # Andy Wingo <wingo@pobox.com>"
sha256sums=(18525079ad29a0d46d15c76581b5d91c8702301bfd821666d2e1d13726162811 # guile-3.0.9.tar.gz
6404578b1f42eae41bfd577ddb1da9168221d16e3cef09c0e2950075a10565f0) # guile-3.0.9.tar.gz.sig