jobcore/guile/PKGBUILD.old

55 lines
1.6 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcore/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=guile
pkgver=2.2.7
pkgrel=03
pkgdesc='Portable, embeddable Scheme implementation written in C'
url='https://www.gnu.org/software/guile/'
arch=(x86_64)
groups=( jobbot )
depends=(gmp libltdl ncurses texinfo libunistring gc libffi)
source=(https://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.gz{,.sig})
prepare() {
cd $pkgname-$pkgver
sed -e '/test-out-of-memory/d' -i test-suite/standalone/Makefile.am # Disable test known to fail https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=966301
autoreconf -if
}
build() {
cd $pkgname-$pkgver
./configure --prefix=/usr \
--disable-static \
--disable-error-on-warning
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}
#check() {
# cd $pkgname-$pkgver
# make check
#}
package() {
make -C $pkgname-$pkgver DESTDIR="$pkgdir" install
rm "$pkgdir"/usr/lib/libguile-2.?.so.*-gdb.scm
}
#---- license gpg-key sha256sums ----
license=(GPL)
validpgpkeys=('3CE464558A84FDC69DB40CFB090B11993D9AEBB5' # Ludovic Courtès <ludo@gnu.org>
'FF478FB264DE32EC296725A3DDC0F5358812F8F2' # Andy Wingo
'4FD4D288D445934E0A14F9A5A8803732E4436885') # Andy Wingo <wingo@pobox.com>"
sha256sums=(44b4c5fbbe257ccdebea18420212c9b3e90c3c86a54920d8554039fc6769a007 # guile-2.2.7.tar.gz
cf4b0fcf9859abf7048876f48f01ec716b3d6d912385dbbf2197eaa42dafaa08) #guile-2.2.7.tar.gz.sig