jobcore/hwdata/PKGBUILD

42 lines
1002 B
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcore/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=hwdata
pkgver=0.381
pkgrel=01
pkgdesc="hardware identification databases"
makedepends=('git')
replaces=('hwids')
conflicts=(hwids)
url=https://github.com/vcrhonek/hwdata
source=("git+https://github.com/vcrhonek/hwdata.git#tag=v${pkgver}?signed")
build() {
cd ${pkgname}
./configure --prefix=/usr --disable-blacklist
}
# make
package() {
cd ${pkgname}
make DESTDIR="${pkgdir}" install
}
#---- license gpg-key sha256sums ----
arch=(x86_64)
license=('GPL-2.0-or-later')
validpgpkeys=('3C40194FB79138CE0F78FD4919C2F062574F5403') # Vitezslav Crhonek
sha256sums=(SKIP)
## 7150e0f4bdc24b5a0204ea8622ea600a788ee98a65bcdf14afa9032bafacddf9 hwdata-0.381-01-x86_64.pkg.tar.lz