jobcore/icu/PKGBUILD

89 lines
3.7 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcore/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
## **** This is not on testing yet, it is not ready to be used till its dependents are built ***
## the current stable version is 72.1 and the patch is ommitted
pkgname=icu
pkgver=74.2
pkgrel=02
pkgdesc="International Components for Unicode library"
groups=( jobbot )
url="https://icu.unicode.org"
depends=('gcc-libs' 'glibc' 'sh')
makedepends=('python')
provides=(libicu{data,i18n,io,test,tu,uc}.so)
# options=('debug') ### uncomment this for debug pkg
source=(https://github.com/unicode-org/icu/releases/download/release-${pkgver//./-}/${pkgname}4c-${pkgver//./_}-src.tgz{,.asc}
ICU-22132.patch
https://github.com/unicode-org/icu/releases/download/release-74-2/SHASUM512.txt
LICENSE)
prepare() {
cd icu/source
# Required fix for thunderbird 115 to show Calendar and sidebar properly
# https://bugzilla.mozilla.org/show_bug.cgi?id=1843007
# https://unicode-org.atlassian.net/browse/ICU-22132
patch -Np1 < "../../ICU-22132.patch"
}
build() {
cd icu/source
./configure --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--sbindir=/usr/bin
make
}
check() {
cd icu/source
make check
}
package() {
cd icu/source
make DESTDIR="${pkgdir}" install
# Install license
install -Dm644 "${srcdir}"/LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=('LicenseRef-Unicode-3.0'
'BSD-2-Clause'
'BSD-3-Clause')
#validpgpkeys=('BA90283A60D67BA0DD910A893932080F4FB419E3') # "Steven R. Loomis (filfla-signing) <srloomis@us.ibm.com>"
#validpgpkeys+=('9731166CD8E23A83BEE7C6D3ACA5DBE1FD8FABF1') # "Steven R. Loomis (ICU Project) <srl@icu-project.org>"
validpgpkeys+=('FFA9129A180D765B7A5BEA1C9B432B27D1BA20D7') # "Fredrik Roubert <fredrik@roubert.name>"
#validpgpkeys+=('E4098B78AFC94394F3F49AA903996C7C83F12F11') # "keybase.io/srl295 <srl295@keybase.io>"
#validpgpkeys+=('4569BBC09DA846FC91CBD21CE1BBA44593CF2AE0') # "Steven R. Loomis (codesign-qormi) <srloomis@us.ibm.com>"
#validpgpkeys=('0E51E7F06EF719FBD072782A5F56E5AFA63CCD33') #"Craig Cornelius (For use with ICU releases) <ccornelius@google.com>"
validpgpkeys=('3DA35301A7C330257B8755754058F67406EAA6AB') # Craig Cornelius <ccornelius@google.com>
## https://github.com/unicode-org/icu/releases/download/release-74-2/SHASUM512.txt
## e6c7876c0f3d756f3a6969cad9a8909e535eeaac352f3a721338b9cbd56864bf7414469d29ec843462997815d2ca9d0dab06d38c37cdd4d8feb28ad04d8781b0
## icu4c-74_2-src.tgz
sha512sums=('e6c7876c0f3d756f3a6969cad9a8909e535eeaac352f3a721338b9cbd56864bf7414469d29ec843462997815d2ca9d0dab06d38c37cdd4d8feb28ad04d8781b0'
'SKIP'
'1178062ccfcf7ecc698c64132b3612e73f9c4b0bbfaa668ae2039f3eb4cb2722d0b08a9f45b057da10def7a308d5c8d14c0c644892e7f11092c9cc488c850ab7'
'SKIP'
'c1c3b2deaf2aeb1d90c1ca85d57db921e140e5087c1eba579dabaca94568a840a0e105145b8016f3b7269216ddc1b0ac56e1d5d1753129a99367e51e2080a6b0')
sha256sums=(68db082212a96d6f53e35d60f47d38b962e9f9d207a74cfac78029ae8ff5e08c # icu4c-74_2-src.tgz
211e8f75f1e15354e197b88566bf66232252df6ab162002c8ab6fe9fa51b29dc # icu4c-74_2-src.tgz.asc
f534b472dd7a6961591466eef542e2c3ad698d3008c9b6af813c66cbc0b4dd8e # ICU-22132.patch
f0f7e6e050a0a2371d2bb49aa5ecfdd713b59eca4702754bd3f646140f31aaee # SHASUM512.txt
f3005e195ff74d8812cc1f182a1c446fab678d70a10e3dada497585befee5416) # LICENSE
## f9edafc0de87e56e28c06133686ac6e121907f7410303f652cd198058cdb5f5d icu-74.2-02-x86_64.pkg.tar.lz