jobcore/iputils/PKGBUILD

49 lines
1.3 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcore/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=iputils
# Commit date + git rev-parse --short origin/master
_rev=84cdf26
pkgver=20240117
pkgrel=01
pkgdesc="Network monitoring tools, including ping w/o systemd"
#url="http://www.skbuff.net/iputils/"
url="https://github.com/iputils/iputils"
depends=('libcap' 'libidn2')
makedepends=('perl-sgmls' 'git' 'docbook-xsl' 'meson' 'iproute')
conflicts=('netkit-base' 'arping')
replaces=('netkit-base')
#options=(debug) ### uncomment for the debug pkg
source=("git+https://github.com/iputils/iputils.git#tag=${pkgver}?signed")
build() {
mkdir -p build
cd build
arch-meson ../$pkgname
ninja
}
package() {
cd build
DESTDIR="$pkgdir" ninja install
install -vDm 644 "../$pkgname/Documentation/LICENSE.BSD3" -t "$pkgdir/usr/share/licenses/$pkgname"
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=('BSD-3-Clause' 'GPL-2.0-or-later')
validpgpkeys=('2016FEA4858B1C36B32E833AC0DEC2EE72F33A5F') # Petr Vorel
sha256sums=(SKIP)
## b865057d80cdf9d76f741569a6e62c968b2e2d7fac1f677f8f9fb08dc9df2750 iputils-20240117-01-x86_64.pkg.tar.lz