jobcore/jobo66/PKGBUILD

49 lines
2.0 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcore/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=jobo66
pkgdesc="installs minimal s6 & 66 pre-0.7.0 edition needed software equivalent to the runit setup on joborun to boot w/ s6/66 and provide user level service supervision"
pkgver=0.1.2
pkgrel=01
makedepends=(glibc sh)
groups=('66-EOL')
conflicts=(opensysusers '66>0.6.2.0' 'oblibs>0.1.4.0') # obsysusers takes over what opensysusers does with runit alone
source=(jobo66.txt)
install=jobo66.install
package() {
depends=(skalibs execline s6 s6-dns s6-linux-utils s6-networking s6-portable-utils s6-rc
oblibs 66 66-tools boot-66serv boot@-66serv modules joborun66 obsysusers opentmpfiles
consolekit2 'oblog=0.1.1.0-03' '66-service-scripts')
install -Dm 0644 $srcdir/jobo66.txt $pkgdir/etc/66/jobo66.txt
mkdir -p $pkgdir/usr/bin
## replaces runit functionality when opensysusers is replaced by obsysusers
ln -s /usr/bin/obsysusers $pkgdir/usr/bin/sysusers
# post-install/post-upgrade in jobo66 makes sure that the directory and contents
# if existing belong to s6log:log and not root:root
# This must be a bug in 66 allowing some process under some conditions to allow
# root to write into the directory
mkdir -p $pkgdir/var/log/66
}
# All observice repository (pkg -Sl observice) are for 66>=0.7.0.0 for 66-EOL use
# 66-service-scripts as retained from before May 2024
# See also additional or more minimalistic and runit like services for 66 from mobinmob
# https://codeberg.org/mobinmob/66-voidlinux and https://osdn.net/projects/avyssos/
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=(ISC)
sha256sums=(4e6bef3a968f760ea2c6d57d047ac005d6dc8ae70285993b6c1b4d4aa33fb627) # jobo66.txt
## b2be2f4cef0a59642c3ed27fda93cfd3c4c8ca2e9a1cd224c3282912bfcc9e9e jobo66-0.1.2-01-x86_64.pkg.tar.lz