jobcore/joborun66/PKGBUILD

36 lines
1.3 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcore/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=joborun66
pkgver=0.2
pkgrel=01
pkgdesc='for runit and 66 to coexist the 4 conflicting power functions must be separate in /usr/bin/s6 and /usr/bin/run '
groups=(base)
depends=(sh)
source=(halt poweroff reboot shutdown)
package() {
install -Dm755 halt "${pkgdir}"/usr/local/bin/halt
install -Dm755 poweroff "${pkgdir}"/usr/local/bin/poweroff
install -Dm755 reboot "${pkgdir}"/usr/local/bin/reboot
install -Dm755 shutdown "${pkgdir}"/usr/local/bin/shutdown
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=('GPL')
sha256sums=(c7cc2aab03eb2367e6d127662eb4b464a5b2712a6020592852c30e320741f3f2 # halt
ee13c9d4b1197f5f437ddc8799bfd5e15819a4216ef5fc73fa9d28988a039ac9 # poweroff
f315d6e0e3a8ea945a0d3f8a8a2e211088c33351cb66875e8b07ed365923e652 # reboot
a0930d43fd07e86ffcf5ba059cb0eacd1404f451f908ed966ef4fabb8968ff16) # shutdown
## 981e23e7d49075fde74905ff1d4ef07d2b50b1cff38fee276aa2fcc8e8a627f3 joborun66-0.2-01-x86_64.pkg.tar.lz