jobcore/libbpf/PKGBUILD

42 lines
1.4 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcore/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
# when libbpf is upgraded iproute2 should be rebuilt "afterwards" based on the new libbpf
pkgname=libbpf
pkgver=1.3.0
pkgrel=01
pkgdesc='Library for loading eBPF programs and reading and manipulating eBPF objects from user-space'
url='https://github.com/libbpf/libbpf'
depends=('glibc' 'libelf' 'linux-api-headers')
makedepends=('rsync')
provides=('libbpf.so')
#options=('debug') ### uncomment this to have the debug pkg produced
source=(https://github.com/libbpf/libbpf/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz)
build() {
cd ${pkgname}-${pkgver}
make -C src
}
package() {
cd ${pkgname}-${pkgver}
make -C src DESTDIR="${pkgdir}" LIBSUBDIR=lib install install_headers
install -Dm 644 LICENSE* -t "${pkgdir}/usr/share/licenses/${pkgname}"
install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=('LGPL2.1')
sha256sums=(11db86acd627e468bc48b7258c1130aba41a12c4d364f78e184fd2f5a913d861) # libbpf-1.3.0.tar.gz
## 226bb86e2f2ec43babab450ecbeb14daed128c901b0df4fd7313743f766a7d9f libbpf-1.3.0-01-x86_64.pkg.tar.lz