jobcore/libedit/PKGBUILD

44 lines
1.4 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcore/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=libedit
_pkgver=20230828-3.1
pkgver=${_pkgver/-/_}
pkgrel=01
pkgdesc='Command line editor library providing generic line editing, history, and tokenization functions'
url='https://thrysoee.dk/editline/'
arch=(x86_64)
depends=('glibc' 'ncurses' 'libncursesw.so')
provides=('libedit.so')
# options=('debug') ## uncomment this for debug pkg
source=(${url}/${pkgname}-${_pkgver}.tar.gz)
build() {
cd ${pkgname}-${_pkgver}
./configure --prefix=/usr
make V=1
}
package() {
cd ${pkgname}-${_pkgver}
make DESTDIR="${pkgdir}" install
rm "${pkgdir}"/usr/share/man/man3/history.3 # conflicts with readline
install -Dm 644 "${pkgdir}"/usr/share/man/man3/editline.3 "${pkgdir}"/usr/share/man/man3/el.3
install -Dm 644 ChangeLog -t "${pkgdir}/usr/share/doc/${pkgname}"
install -Dm 644 COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
#---- license gpg-key sha256sums ----
license=('BSD')
sha256sums=(4ee8182b6e569290e7d1f44f0f78dac8716b35f656b76528f699c69c98814dad) # libedit-20230828-3.1.tar.gz
## a38960c16f8a7fe6ec8f0a9bfd60080de15fb2246bf96683144910411a06a15c libedit-20230828_3.1-01-x86_64.pkg.tar.lz