jobcore/libffi/PKGBUILD

60 lines
1.6 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcore/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=libffi
pkgver=3.4.6
pkgrel=01
pkgdesc='Portable foreign programming language function interface library'
url='https://sourceware.org/libffi/'
depends=('glibc')
checkdepends=('dejagnu')
makedepends=('automake' 'autoconf')
provides=('libffi.so')
#options=(debug) ## uncomment this to produce the debug pkg
source=(https://github.com/libffi/libffi/releases/download/v${pkgver}/libffi-${pkgver}.tar.gz)
#prepare() {
# cd $pkgname-$pkgver
# autoreconf -fiv
#}
build() {
cd $pkgname-$pkgver
# remove --disable-exec-static-tramp once ghc and gobject-introspection
# work fine with it enabled (https://github.com/libffi/libffi/pull/647)
./configure \
--prefix=/usr \
--disable-static \
--disable-multi-os-directory \
--disable-exec-static-tramp \
--enable-pax_emutramp
make
}
check() {
make -C $pkgname-$pkgver check
}
package() {
cd $pkgname-$pkgver
make DESTDIR="$pkgdir" install
install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname
install -Dm 644 README.md -t "$pkgdir"/usr/share/doc/$pkgname
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=('MIT')
sha256sums=(b0dea9df23c863a7a50e825440f3ebffabd65df1497108e5d437747843895a4e) # libffi-3.4.6.tar.gz
## 9d92418793f2fe4c8835011a522a7a4d74d895ba951239eff28fe5c369a49285 libffi-3.4.6-01-x86_64.pkg.tar.lz