jobcore/libgcrypt/PKGBUILD

66 lines
2.1 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcore/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=libgcrypt
pkgver=1.10.3
pkgrel=01
pkgdesc="General purpose cryptographic library based on the code from GnuPG w/o systemd"
url="https://www.gnupg.org"
depends=('libgpg-error')
options=('!emptydirs')
#options=('!emptydirs' 'debug') ##### uncomment this line to have the debug pkg produced
# https://www.gnupg.org/download/integrity_check.html
source=(https://gnupg.org/ftp/gcrypt/${pkgname}/${pkgname}-${pkgver}.tar.bz2{,.sig})
prepare() {
cd "${pkgname}"-${pkgver}
# tests fail due to systemd+libseccomp preventing memory syscalls when building in chroots
# t-secmem: line 176: gcry_control (GCRYCTL_INIT_SECMEM, pool_size, 0) failed: General error
# FAIL: t-secmem
# t-sexp: line 1174: gcry_control (GCRYCTL_INIT_SECMEM, 16384, 0) failed: General error
# FAIL: t-sexp
## sed -i "s:t-secmem::" tests/Makefile.am
## sed -i "s:t-sexp::" tests/Makefile.am
## We commented out those two lines above since without systemd ALL tests pass. Thank you Gnu!
autoreconf -vfi
}
build() {
cd "${pkgname}"-${pkgver}
./configure --prefix=/usr \
--disable-static \
--disable-padlock-support \
--disable-systemd
make
}
check() {
cd "${pkgname}"-${pkgver}
make check
}
package() {
cd "${pkgname}"-${pkgver}
make DESTDIR="${pkgdir}" install
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=('LGPL')
#validpgpkeys=('6DAA6E64A76D2840571B4902528897B826403ADA') # "Werner Koch (dist signing 2020)"
validpgpkeys=('AC8E115BF73E2D8D47FA9908E98E9B2D19C6C8BD') # Niibe Yutaka (GnuPG Release Key)
sha256sums=(8b0870897ac5ac67ded568dcfadf45969cfa8a6beb0fd60af2a9eadc2a3272aa # libgcrypt-1.10.3.tar.bz2
267016f908127828556bda0f38aabd1fd3ea501e06de99877cbe453018e4ee56) # libgcrypt-1.10.3.tar.bz2.sig
## 9a85df4401db9f904c1bd79fb88b82d2c740919c3d83568faa556e896a39ab94 libgcrypt-1.10.3-01-x86_64.pkg.tar.lz