jobcore/libisl/PKGBUILD

51 lines
1.4 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcore/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=libisl
pkgver=0.26
pkgrel=02
pkgdesc='Library for manipulating sets and relations of integer points bounded by linear constraints'
url='https://libisl.sourceforge.io'
depends=('gmp')
provides=('isl' 'libisl.so')
replaces=('isl')
options=(staticlibs)
source=("https://libisl.sourceforge.io/isl-${pkgver}.tar.xz")
build() {
cd "${srcdir}"/${pkgname#lib}-${pkgver}
./configure --prefix=/usr
make
}
check() {
cd "${srcdir}"/${pkgname#lib}-${pkgver}
make check || true
}
package() {
cd "${srcdir}"/${pkgname#lib}-${pkgver}
make DESTDIR="${pkgdir}" install
install -dm755 "${pkgdir}"/usr/share/gdb/auto-load/usr/lib/
mv "${pkgdir}"/usr/lib/libisl.so.*-gdb.py "${pkgdir}"/usr/share/gdb/auto-load/usr/lib/
install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=('MIT')
sha256sums=(a0b5cb06d24f9fa9e77b55fabbe9a3c94a336190345c2555f9915bb38e976504) # isl-0.26.tar.xz
## dd9f8e4de297c80f3d85d99a2918d35857662c4ab01ca3e6f6a35f56bbafcb04 libisl-0.26-02-x86_64.pkg.tar.lz