jobcore/libmicrohttpd/PKGBUILD

56 lines
1.6 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcore/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=libmicrohttpd
pkgver=1.0.1
pkgrel=01
pkgdesc="a small C library that is supposed to make it easy to run an HTTP server as part of another application."
url="https://www.gnu.org/software/libmicrohttpd/"
depends=('gnutls')
checkdepends=('curl')
provides=('libmicrohttpd.so')
source=("https://ftp.gnu.org/gnu/libmicrohttpd/$pkgname-$pkgver.tar.gz"{,.sig})
build() {
cd ${pkgname}-${pkgver}
./configure \
--prefix=/usr \
--disable-dependency-tracking \
--disable-examples \
--enable-curl \
--enable-https \
--enable-largefile \
--enable-messages \
--with-pic
make
}
check() {
cd ${pkgname}-${pkgver}
make check
}
package() {
cd ${pkgname}-${pkgver}
make DESTDIR="$pkgdir" install
}
#---- arch license gpg-key and sha256sums ----
arch=(x86_64)
license=('LGPL')
validpgpkeys=('EA812DBEFA5A7EF17DA8F2C1460A317C3326D2AE' # Evgeny Grin (Karlson2k) <k2k@yandex.ru>
'D8423BCB326C7907033929C7939E6BE1E29FC3CC') # Christian Grothoff <christian.grothoff@bfh.ch>
sha256sums=(a89e09fc9b4de34dde19f4fcb4faaa1ce10299b9908db1132bbfa1de47882b94 # libmicrohttpd-1.0.1.tar.gz
f67c9f77ed7cd3b5305623b3b19318e5400369c7a2d8fe685520b8b78d9845a4) # libmicrohttpd-1.0.1.tar.gz.sig
## 1435f2b61cb144d8dad6fbcc14af5ba33818c10db46acb6e68aa99f7e585c73c libmicrohttpd-1.0.1-01-x86_64.pkg.tar.lz