jobcore/libnghttp2/PKGBUILD

81 lines
2.2 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcore/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=libnghttp2
#_tag='69148c95ea5980b52c669135e45bf8204421aa9c' # git rev-parse v${pkgver}
pkgver=1.61.0
pkgrel=01
pkgdesc='Framing layer of HTTP/2 is implemented as a reusable C library'
url='https://nghttp2.org/'
depends=(glibc)
makedepends=('automake' 'autoconf' 'git')
conflicts=('nghttp2<1.20.0-2')
provides=('libnghttp2.so')
#source=(https://github.com/nghttp2/nghttp2/releases/download/v$pkgver/nghttp2-$pkgver.tar.xz)
#source=("git+https://github.com/nghttp2/nghttp2.git#tag=${_tag}?signed"
source=("git+https://github.com/nghttp2/nghttp2.git#tag=v${pkgver}?signed"
'git+https://github.com/ngtcp2/munit.git'
'git+https://github.com/mruby/mruby.git'
'git+https://github.com/tatsuhiro-t/neverbleed.git')
prepare() {
cd nghttp2
git config --file=.gitmodules submodule.tests/munit.url ../munit/
git config --file=.gitmodules submodule.third-party/mruby.url ../mruby/
git config --file=.gitmodules submodule.tests/neverbleed.url ../neverbleed/
git submodule init
git -c protocol.file.allow=always submodule update
autoreconf -i
}
build() {
cd nghttp2
./configure \
--prefix=/usr \
--disable-examples \
--disable-python-bindings \
--enable-lib-only
make
}
check() {
# cd nghttp2-$pkgver
cd nghttp2
make check
}
package() {
# cd nghttp2-$pkgver/lib
cd nghttp2/lib
make DESTDIR="$pkgdir" install
install -Dm644 ../COPYING "$pkgdir/usr/share/licenses/libnghttp2/COPYING"
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=(MIT)
validpgpkeys=('F4F3B91474D1EB29889BD0EF7E8403D5D673C366') # Tatsuhiro Tsujikawa <tatsuhiro.t@gmail.com>
sha512sums=('a347249408552b1928ca42955a094be9c69a56fe9eb4a21ec8ac62c8c99ce8fa13a3fb2b1ba6363c75ac73a169ac62cbd954cfad607e872e821a6348817027e4'
'SKIP'
'SKIP'
'SKIP')
sha256sums=(SKIP
SKIP
SKIP
SKIP)
## 647b5c2059001ede03ab893e4f116a0d44ab083b01f33be53e2b4af4b4b1851c libnghttp2-1.61.0-01-x86_64.pkg.tar.lz