jobcore/libpsl/PKGBUILD

71 lines
2.1 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcore/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=libpsl
pkgver=0.21.5
pkgrel=01
pkgdesc='Public Suffix List library'
url='https://github.com/rockdaboot/libpsl'
# This is intentionally left out
# to minimize chroot for jobbot1
# https://github.com/rockdaboot/libpsl/issues/157
# /usr/bin/psl-make-dafsa script will require python to work!! Otherwise both python and libnsl
# are a waste of speace!
#
#depends=('libidn2' 'libunistring' 'python')
depends=('libidn2' 'libunistring')
makedepends=('libxslt' 'publicsuffix-list' 'gtk-doc')
provides=('libpsl.so')
source=(https://github.com/rockdaboot/libpsl/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz{,.sig})
prepare() {
cd ${pkgname}-${pkgver}
rm -frv list
autoreconf -fiv
}
build() {
cd ${pkgname}-${pkgver}
./configure \
--prefix=/usr \
--disable-static \
--disable-dependency-tracking \
--enable-man \
--enable-gtk-doc \
--enable-{builtin,runtime}=libidn2 \
--with-psl-file=/usr/share/publicsuffix/effective_tld_names.dat \
--with-psl-testfile=/usr/share/publicsuffix/test_psl.txt
LC_CTYPE=en_US.UTF-8 make
}
check() {
cd ${pkgname}-${pkgver}
make check
}
package() {
depends+=('libidn2.so' 'libunistring.so')
cd ${pkgname}-${pkgver}
make DESTDIR="${pkgdir}" install
install -Dm 644 COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=('MIT')
validpgpkeys=('1CB27DBC98614B2D5841646D08302DB6A2670428') # Tim Rühsen <tim.ruehsen@gmx.de>
sha256sums=(1dcc9ceae8b128f3c0b3f654decd0e1e891afc6ff81098f227ef260449dae208 # libpsl-0.21.5.tar.gz
87d819c4b61b6880ebe788edb411b92ac6ac47c7a2fb72899a8446a485d4607a) # libpsl-0.21.5.tar.gz.sig
## 1a9e9d779ad5976c47ffe77ef997c04cf6bbaecb038d3d97774c6c98823761f8 libpsl-0.21.5-01-x86_64.pkg.tar.lz