jobcore/libsasl/PKGBUILD

101 lines
3.1 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcore/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
# NOTE: upgrade libsasl in tandem with extra/cyrus-sasl
# As one PKGBUILD can (currently) not provide packages for several
# repositories, libsasl and the rest of cyrus-sasl are provided separately
# (else this would require mariadb and postgresql in [core])
_name=cyrus-sasl
pkgname=libsasl
pkgver=2.1.28
pkgrel=04 ## rebuilt against Obarun's updated postgresql
pkgdesc="Cyrus Simple Authentication Service Layer (SASL) library w/o systemd"
arch=('x86_64')
url="https://www.cyrusimap.org/sasl/"
depends=(gdbm libgdbm.so glibc openssl)
makedepends=(krb5 libldap mariadb-libs postgresql-libs sqlite)
provides=(libsasl2.so)
# options=(debug) ## uncomment this to produce the debug package
source=(https://github.com/cyrusimap/$_name/releases/download/$_name-$pkgver/$_name-$pkgver.tar.gz{,.sig})
prepare() {
cd $_name-$pkgver
autoreconf -fiv
}
build() {
cd $_name-$pkgver
./configure --prefix=/usr \
--disable-krb4 \
--disable-macos-framework \
--disable-otp \
--disable-passdss \
--disable-srp \
--disable-srp-setpass \
--disable-static \
--enable-alwaystrue \
--enable-anon \
--enable-auth-sasldb \
--enable-checkapop \
--enable-cram \
--enable-digest \
--enable-gssapi \
--enable-ldapdb \
--enable-login \
--enable-ntlm \
--enable-plain \
--enable-shared \
--enable-sql \
--infodir=/usr/share/info \
--mandir=/usr/share/man \
--sbin=/usr/bin \
--sysconfdir=/etc \
--with-dblib=gdbm \
--with-devrandom=/dev/urandom \
--with-configdir=/etc/sasl2:/etc/sasl:/usr/lib/sasl2 \
--with-ldap \
--with-mysql=/usr \
--with-pam \
--with-pgsql=/usr/lib \
--with-saslauthd=/var/run/saslauthd \
--with-sqlite3=/usr/lib \
--without-systemd
# prevent excessive overlinking by libtool
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}
check() {
make -k check -C $_name-$pkgver
}
package() {
local _target
make DESTDIR="$pkgdir" install-pkgconfigDATA -C $_name-$pkgver
for _target in include lib sasldb plugins utils; do
make DESTDIR="$pkgdir" install -C $_name-$pkgver/$_target
done
install -vDm 644 $_name-$pkgver/COPYING -t "$pkgdir/usr/share/licenses/$pkgname/"
# remove files provided by extra/cyrus-sasl
rm -fv "$pkgdir"/usr/lib/sasl2/lib{gs2,gssapiv2,ldapdb,sql}.so*
}
#---- license gpg-key sha256sums ----
license=('custom')
validpgpkeys=(829F339F8C296FE80F409D93E3D7C118C7B9F46A # Partha Susarla <mail@spartha.org>
DEA1999F0CDB1AAEBA001E0DBEE3E3B4D2F06546) # Quanah Gibson-Mount <quanah@fast-mail.org>
sha256sums=(7ccfc6abd01ed67c1a0924b353e526f1b766b21f42d4562ee635a8ebfc5bb38c # cyrus-sasl-2.1.28.tar.gz
e6169548f42234eb2b1af9719415016a57116835b8ea494596f52743b49971fd) # cyrus-sasl-2.1.28.tar.gz.sig