jobcore/libsecret/PKGBUILD

55 lines
1.6 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcore/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
## Note: Odd behavior but this works on our builder
## Makepkg 1st run, dbus test fails, makepkg with skipcheck
## Install new pkg, clean src/pkg and remove made pkg, rebuild with checks uncommented
## Test passes 0.21.3 but not 0.21.4. Ohh.. well .. we will try again next time :)
pkgname=libsecret
pkgver=0.21.4
pkgrel=01
pkgdesc="Library for storing and retrieving passwords and other secrets"
#url="https://wiki.gnome.org/Projects/Libsecret"
url="https://gnome.pages.gitlab.gnome.org/libsecret/"
depends=(glib2 libgcrypt tpm2-tss)
checkdepends=(dbus-python dbus-glib python-gobject gjs)
makedepends=(docbook-xsl gobject-introspection vala git gtk-doc meson valgrind)
optdepends=('org.freedesktop.secrets: secret storage backend')
provides=(libsecret-1.so)
_commit=6b5a6c28afc6dd93c232a4907a87c881079ff91b # tags/0.21.4^0
source=("git+https://gitlab.gnome.org/GNOME/libsecret.git#commit=$_commit")
pkgver() {
cd $pkgname
git describe --tags | sed 's/-/+/g'
}
build() {
arch-meson $pkgname build
meson compile -C build
}
check() {
dbus-run-session meson test -C build --print-errorlogs
}
package() {
DESTDIR="$pkgdir" meson install -C build
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=(LGPL-2.1-or-later)
sha256sums=(SKIP)
##