jobcore/libusb/PKGBUILD

56 lines
1.5 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcore/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=libusb
pkgver=1.0.27
pkgrel=01
pkgdesc="A cross-platform library to access USB devices w/o systemd - git version"
url="https://libusb.info/"
_url="https://github.com/libusb/libusb"
depends=(glibc libeudev)
makedepends=(automake autoconf)
provides=(libusb-1.0.so)
conflicts=(libusb-git)
#options=(debug) ## uncomment this line to have the debug pkg produced
source=($_url/releases/download/v$pkgver/$pkgname-$pkgver.tar.bz2)
prepare() {
cd $pkgname-$pkgver
autoreconf -fiv
}
build() {
cd $pkgname-$pkgver
./configure --prefix=/usr
# prevent excessive overlinking due to libtool
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}
check() {
make -k check -C $pkgname-$pkgver
}
package() {
depends+=(libeudev)
make DESTDIR="$pkgdir" install -C $pkgname-$pkgver
install -vDm 644 $pkgname-$pkgver/{AUTHORS,ChangeLog,README} -t "$pkgdir/usr/share/doc/$pkgname/"
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=(LGPL-2.1-or-later)
sha256sums=(ffaa41d741a8a3bee244ac8e54a72ea05bf2879663c098c82fc5757853441575) # libusb-1.0.27.tar.bz2
## 520789b61f049e9987123006871f127d3f99412c2de069f20a455fbc5ba71f07 libusb-1.0.27-01-x86_64.pkg.tar.lz