jobcore/libxml2/PKGBUILD

98 lines
2.4 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcore/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
#pkgbase=libxml2
#pkgname=(libxml2 libxml2-docs)
pkgname=libxml2
pkgver=2.12.6
pkgrel=02
# mixup between jobcore and staging 4/22 rebuild on jobcore used staging PKGBUILD-arch
# so staging pkgrel is bumped up one to distinguish from jobcore's build
pkgdesc="XML C parser and toolkit"
url="https://gitlab.gnome.org/GNOME/libxml2/-/wikis/home"
depends=(zlib xz icu readline ncurses)
makedepends=(python git)
optdepends=('python: Python bindings')
provides=(libxml2.so)
#options=(debug) ## uncomment this to have the debug pkg produced
_commit=505e2e872e767405be565aa9d47ae9d6d5677f79 # tags/v2.12.6^0
source=("git+https://gitlab.gnome.org/GNOME/libxml2.git#commit=$_commit"
0001-HACK-Don-t-run-fuzzing-tests.patch
https://www.w3.org/XML/Test/xmlts20130923.tar.gz)
pkgver() {
cd libxml2
git describe --tags | sed 's/-rc/rc/;s/^v//;s/[^-]*-g/r&/;s/-/+/g'
}
prepare() {
cd libxml2
# Use xmlconf from conformance test suite
ln -s ../xmlconf
# Do not run fuzzing tests
git apply -3 ../0001-HACK-Don-t-run-fuzzing-tests.patch
NOCONFIGURE=1 ./autogen.sh
}
build() {
cd libxml2
./configure \
--prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
--disable-static \
--with-history \
--with-python=/usr/bin/python \
--with-icu \
--with-legacy \
--with-threads
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}
check() {
cd libxml2
make check
}
#package_libxml2() {
package() {
cd libxml2
make DESTDIR="$pkgdir" install
mkdir -p ../doc/usr/share
mv "$pkgdir"/usr/share/{doc,gtk-doc} -t ../doc/usr/share
install -Dm644 Copyright -t "$pkgdir/usr/share/licenses/$pkgname"
}
#package_libxml2-docs() {
# pkgdesc+=" (documentation)"
# depends=()
#
# mv doc/* "$pkgdir"
#}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=(MIT)
sha256sums=(SKIP
60921b7894753a079659369b49b718c83d09edd49de76503850e5560af778c3a # 0001-HACK-Don-t-run-fuzzing-tests.patch
9b61db9f5dbffa545f4b8d78422167083a8568c59bd1129f94138f936cf6fc1f) # xmlts20130923.tar.gz
## 63dce83864d53dee33720212b25319020d41cbe8630fdf0e3ef79f0ff50f2d3f libxml2-2.12.6-02-x86_64.pkg.tar.lz