jobcore/linux-lts/PKGBUILD-ck-failed

347 lines
13 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcomm/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
### BUILD OPTIONS
# Set these variables to ANYTHING that is not null to enable them
# Tweak kernel options prior to a build via nconfig
#_makenconfig=y
# Optionally select a sub architecture by number if building in a clean chroot
# Leaving this entry blank will require user interaction during the build
# which will cause a failure to build if using makechrootpkg. Note that the
# generic (default) option is 32.
#
# Note - the march=native option is unavailable by this method, use the nconfig
# and manually select it.
#
# 1. AMD Opteron/Athlon64/Hammer/K8 (MK8)
# 2. AMD Opteron/Athlon64/Hammer/K8 with SSE3 (MK8SSE3)
# 3. AMD 61xx/7x50/PhenomX3/X4/II/K10 (MK10)
# 4. AMD Barcelona (MBARCELONA)
# 5. AMD Bobcat (MBOBCAT)
# 6. AMD Jaguar (MJAGUAR)
# 7. AMD Bulldozer (MBULLDOZER)
# 8. AMD Piledriver (MPILEDRIVER)
# 9. AMD Steamroller (MSTEAMROLLER)
# 10. AMD Excavator (MEXCAVATOR)
# 11. AMD Zen (MZEN)
# 12. AMD Zen 2 (MZEN2)
# 13. Intel P4 / older Netburst based Xeon (MPSC)
# 14. Intel Atom (MATOM)
# 15. Intel Core 2 (MCORE2)
# 16. Intel Nehalem (MNEHALEM)
# 17. Intel Westmere (MWESTMERE)
# 18. Intel Silvermont (MSILVERMONT)
# 19. Intel Goldmont (MGOLDMONT)
# 20. Intel Goldmont Plus (MGOLDMONTPLUS)
# 21. Intel Sandy Bridge (MSANDYBRIDGE)
# 22. Intel Ivy Bridge (MIVYBRIDGE)
# 23. Intel Haswell (MHASWELL)
# 24. Intel Broadwell (MBROADWELL)
# 25. Intel Skylake (MSKYLAKE)
# 26. Intel Skylake X (MSKYLAKEX)
# 27. Intel Cannon Lake (MCANNONLAKE)
# 28. Intel Ice Lake (MICELAKE)
# 29. Intel Cascade Lake (MCASCADELAKE)
# 30. Intel Cooper Lake (MCOOPERLAKE)
# 31. Intel Tiger Lake (MTIGERLAKE)
# 32. Generic-x86-64 (GENERIC_CPU)
# 33. Native optimizations autodetected by GCC (MNATIVE)
_subarch=22
# Compile ONLY used modules to VASTLYreduce the number of modules built
# and the build time.
#
# To keep track of which modules are needed for your specific system/hardware,
# give module_db script a try: https://aur.archlinux.org/packages/modprobed-db
# This PKGBUILD read the database kept if it exists
#
# More at this wiki page ---> https://wiki.archlinux.org/index.php/Modprobed-db
_localmodcfg=/home/make/.config/modprobed.db
### IMPORTANT: Do no edit below this line unless you know what you're doing
pkgbase=linux-ck-lts
pkgver=5.10.172
pkgrel=03
_ckpatchversion=1
url="https://wiki.archlinux.org/index.php/Linux-ck"
#makedepends=(
# bc kmod libelf cpio perl tar xz
#)
makedepends=(bc kmod libelf pahole cpio perl tar xz kmod
xmlto python-sphinx python-sphinx_rtd_theme graphviz imagemagick) # python-six
options=('!strip')
_ckpatch="patch-5.10-ck${_ckpatchversion}"
_gcc_more_v='20201113'
source=(
"https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-$pkgver.tar".{xz,sign}
config # the main kernel config file
sha256sums::https://cdn.kernel.org/pub/linux/kernel/v5.x/sha256sums.asc
"enable_additional_cpu_optimizations-$_gcc_more_v.tar.gz::https://github.com/graysky2/kernel_compiler_patch/archive/$_gcc_more_v.tar.gz"
"http://ck.kolivas.org/patches/5.0/5.10/5.10-ck${_ckpatchversion}/$_ckpatch.xz"
0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
0002-fix-nvme.patch)
export KBUILD_BUILD_HOST=joborun
export KBUILD_BUILD_USER=$pkgbase
export KBUILD_BUILD_TIMESTAMP="$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EPOCH})"
prepare() {
cd linux-${pkgver}
echo "Setting version... $pkgver"
scripts/setlocalversion --save-scmversion
echo "-$pkgrel" > localversion.10-pkgrel
echo "${pkgbase#linux}" > localversion.20-pkgname
local src
for src in "${source[@]}"; do
src="${src%%::*}"
src="${src##*/}"
[[ $src = 0*.patch ]] || continue
echo "Applying patch $src..."
patch -Np1 < "../$src"
done
echo "Setting config..."
cp ../config .config
# disable CONFIG_DEBUG_INFO=y at build time otherwise memory usage blows up
# and can easily overwhelm a system with 32 GB of memory using a tmpfs build
# partition ... this was introduced by FS#66260, see:
# https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/linux&id=663b08666b269eeeeaafbafaee07fd03389ac8d7
scripts/config --disable CONFIG_DEBUG_INFO
scripts/config --disable CONFIG_CGROUP_BPF
scripts/config --disable CONFIG_BPF_LSM
scripts/config --disable CONFIG_BPF_PRELOAD
scripts/config --disable CONFIG_BPF_LIRC_MODE2
scripts/config --disable CONFIG_BPF_KPROBE_OVERRIDE
# make it size optimized
# scripts/config --disable CONFIG_CC_OPTIMIZE_FOR_PERFORMANCE
# scripts/config --enable CONFIG_CC_OPTIMIZE_FOR_SIZE
# https://bbs.archlinux.org/viewtopic.php?pid=1824594#p1824594
scripts/config --enable CONFIG_PSI_DEFAULT_DISABLED
# https://bbs.archlinux.org/viewtopic.php?pid=1863567#p1863567
scripts/config --disable CONFIG_LATENCYTOP
scripts/config --disable CONFIG_SCHED_DEBUG
# FS#66613
# https://bugzilla.kernel.org/show_bug.cgi?id=207173#c6
scripts/config --disable CONFIG_KVM_WERROR
# fix naming schema in EXTRAVERSION of ck patch set
sed -i -re "s/^(.EXTRAVERSION).*$/\1 = /" "../${_ckpatch}"
# ck patchset itself
echo "Patching with ck patchset..."
patch -Np1 -i ../"${_ckpatch}"
# non-interactively apply ck1 default options
# this isn't redundant if we want a clean selection of subarch below
make olddefconfig
# https://github.com/graysky2/kernel_compiler_patch
# make sure to apply after olddefconfig to allow the next section
echo "Patching to enable GCC optimization for other uarchs..."
patch -Np1 -i "$srcdir/kernel_compiler_patch-$_gcc_more_v/enable_additional_cpu_optimizations_for_gcc_v10.1+_kernel_v5.8+.patch"
if [ -n "$_subarch" ]; then
# user wants a subarch so apply choice defined above interactively via 'yes'
yes "$_subarch" | make oldconfig
else
# no subarch defined so allow user to pick one
make oldconfig
fi
### Optionally load needed modules for the make localmodconfig
# See https://aur.archlinux.org/packages/modprobed-db
if [ -n "$_localmodcfg" ]; then
if [ -f $HOME/.config/modprobed.db ]; then
echo "Running Steven Rostedt's make localmodconfig now"
make LSMOD=$HOME/.config/modprobed.db localmodconfig
else
echo "No modprobed.db data found"
exit
fi
fi
make -s kernelrelease > version
echo "Prepared $pkgbase version $(<version)"
[[ -z "$_makenconfig" ]] || make nconfig
# save configuration for later reuse
cat .config > "${startdir}/config.last"
# uncomment if you want to build with distcc
### sed -i '/HAVE_GCC_PLUGINS/d' arch/x86/Kconfig
}
build() {
cd linux-${pkgver}
make all
}
_package() {
pkgdesc="The long term support version ${pkgbase/linux/Linux} kernel and modules with the ck1 patchset featuring MuQSS CPU scheduler. Mostly just a fork of graysky's older Linux-CK package."
depends=(coreutils kmod initramfs)
optdepends=('crda: to set the correct wireless channels of your country'
'linux-firmware: firmware images needed for some devices')
provides=(VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE)
#groups=('ck-generic')
cd linux-${pkgver}
local kernver="$(<version)"
local modulesdir="$pkgdir/usr/lib/modules/$kernver"
echo "Installing boot image..."
# systemd expects to find the kernel here to allow hibernation
# https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
#install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
#
# hard-coded path in case user defined CC=xxx for build which causes errors
# see this FS https://bugs.archlinux.org/task/64315
install -Dm644 arch/x86/boot/bzImage "$modulesdir/vmlinuz"
# Used by mkinitcpio to name the kernel
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
echo "Installing modules..."
#make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 modules_install
# not needed since not building with CONFIG_DEBUG_INFO=y
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
# remove build and source links
rm "$modulesdir"/{source,build}
}
_package-headers() {
pkgdesc="Headers and scripts for building modules for ${pkgbase/linux/Linux} kernel"
depends=("$pkgbase") # added to keep kernel and headers packages matched
#groups=('ck-generic')
cd linux-${pkgver}
local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
echo "Installing build files..."
install -Dt "$builddir" -m644 .config Makefile Module.symvers System.map \
localversion.* version vmlinux
install -Dt "$builddir/kernel" -m644 kernel/Makefile
install -Dt "$builddir/arch/x86" -m644 arch/x86/Makefile
cp -t "$builddir" -a scripts
# required when STACK_VALIDATION is enabled
# add objtool for external module building and enabled VALIDATION_STACK option
install -Dt "$builddir/tools/objtool" tools/objtool/objtool
# add xfs and shmem for aufs building
mkdir -p "$builddir"/{fs/xfs,mm}
# # required when DEBUG_INFO_BTF_MODULES is enabled
# install -Dt "$builddir/tools/bpf/resolve_btfids" tools/bpf/resolve_btfids/resolve_btfids
echo "Installing headers..."
cp -t "$builddir" -a include
cp -t "$builddir/arch/x86" -a arch/x86/include
install -Dt "$builddir/arch/x86/kernel" -m644 arch/x86/kernel/asm-offsets.s
install -Dt "$builddir/drivers/md" -m644 drivers/md/*.h
install -Dt "$builddir/net/mac80211" -m644 net/mac80211/*.h
# https://bugs.archlinux.org/task/13146
install -Dt "$builddir/drivers/media/i2c" -m644 drivers/media/i2c/msp3400-driver.h
# https://bugs.archlinux.org/task/20402
install -Dt "$builddir/drivers/media/usb/dvb-usb" -m644 drivers/media/usb/dvb-usb/*.h
install -Dt "$builddir/drivers/media/dvb-frontends" -m644 drivers/media/dvb-frontends/*.h
install -Dt "$builddir/drivers/media/tuners" -m644 drivers/media/tuners/*.h
# https://bugs.archlinux.org/task/71392
# install -Dt "$builddir/drivers/iio/common/hid-sensors" -m644 drivers/iio/common/hid-sensors/*.h
echo "Installing KConfig files..."
find . -name 'Kconfig*' -exec install -Dm644 {} "$builddir/{}" \;
echo "Removing unneeded architectures..."
local arch
for arch in "$builddir"/arch/*/; do
[[ $arch = */x86/ ]] && continue
echo "Removing $(basename "$arch")"
rm -r "$arch"
done
echo "Removing documentation..."
rm -r "$builddir/Documentation"
echo "Removing broken symlinks..."
find -L "$builddir" -type l -printf 'Removing %P\n' -delete
echo "Removing loose objects..."
find "$builddir" -type f -name '*.o' -printf 'Removing %P\n' -delete
echo "Stripping build tools..."
local file
while read -rd '' file; do
case "$(file -Sib "$file")" in
application/x-sharedlib\;*) # Libraries (.so)
strip -v $STRIP_SHARED "$file" ;;
application/x-archive\;*) # Libraries (.a)
strip -v $STRIP_STATIC "$file" ;;
application/x-executable\;*) # Binaries
strip -v $STRIP_BINARIES "$file" ;;
application/x-pie-executable\;*) # Relocatable binaries
strip -v $STRIP_SHARED "$file" ;;
esac
done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
#echo "Stripping vmlinux..."
#strip -v $STRIP_STATIC "$builddir/vmlinux"
# not needed since not building with CONFIG_DEBUG_INFO=y
echo "Adding symlink..."
mkdir -p "$pkgdir/usr/src"
ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"
}
pkgname=("$pkgbase" "$pkgbase-headers")
for _p in "${pkgname[@]}"; do
eval "package_$_p() {
$(declare -f "_package${_p#$pkgbase}")
_package${_p#$pkgbase}
}"
done
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=(GPL2)
validpgpkeys=(ABAF11C65A2970B130ABE3C479BE3E4300411886 # Linus Torvalds
647F28654894E3BD457199BE38DBBDC86092693E) # Greg Kroah-Hartman
sha256sums=(f20dbae344df1c33cad617f7670c5e061557f592f422c842d3b30155df2927b1 # linux-5.10.172.tar.xz
5b11b4a327cad48491a3efb8420279f30142ee79844ed86e7bba132eb5b0746c # linux-5.10.172.tar.sign
ae8b8422878ca876a0054c00e55075ce25016a0539460a616006b3539e482e55 # config
787a1459e4dbb09e8cf03db800681e7d4451ca96ca93d6cea3dbcf58bea65862 # sha256sums
b26dec8ef65003c52aab22c46251bcbd8c1ce6618ff55fa4270fd990b4e3bf7d # enable_additional_cpu_optimizations-20201113.tar.gz
09421fe7e63b5792de189fa354bdbdad41235200b6924214c6834cb709902422 # patch-5.10-ck1.xz
96a72e1652314215da7140956c3abcf495cafd00811eda3cf4ce03ec5f791f1e # 0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
0e14c0d788262a9781d8ba1d6e894f30877f015ccf0b6d768d759eac48bcede9) # 0002-fix-nvme.patch
##
4076fafd2c0a4fbcf76a41b8db47c75d2d6ca4a791d0ec18621410ae2bc000f3 config