jobcore/linux/PKGBUILD

239 lines
8.5 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcore/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgbase=linux
pkgver=5.15.154
pkgrel=010 # amdfam10
pkgdesc='Linux LTS 5.15 w/o zstd ipv6 - amdfam10 '
url="https://www.kernel.org/"
makedepends=(bc kmod libelf pahole cpio perl tar xz)
# gettext python-sphinx python-sphinx_rtd_theme graphviz imagemagick)
# texlive-latexextra) ## for building docs
options=('!strip')
_srcname=linux-$pkgver
url="https://cdn.kernel.org/pub/linux/kernel"
source=($url/v5.x/$_srcname.tar.{xz,sign}
config # the main kernel config file
0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
0003-iommu-intel-do-deep-dma-unmapping-to-avoid-kernel-fl.patch
0004-Bluetooth-btintel-Fix-bdaddress-comparison-with-garb.patch
0005-lg-laptop-Recognize-more-models.patch
i915-vga-arbiter.patch
sha256sums::https://cdn.kernel.org/pub/linux/kernel/v5.x/sha256sums.asc)
export KBUILD_BUILD_HOST=joborun
export KBUILD_BUILD_USER=$pkgbase
export KBUILD_BUILD_TIMESTAMP="$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EPOCH})"
#_make() {
# test -s version
# make KERNELRELEASE="$(<version)" "$@"
#}
prepare() {
cd $_srcname
echo "Setting version... $pkgver"
scripts/setlocalversion --save-scmversion
echo "-$pkgrel" > localversion.10-pkgrel
echo "${pkgbase#linux}" > localversion.20-pkgname
# make defconfig
# make -s kernelrelease > version
# make mrproper
local src
for src in "${source[@]}"; do
src="${src%%::*}"
src="${src##*/}"
[[ $src = *.patch ]] || continue
echo "Applying patch $src..."
patch -Np1 < "../$src"
done
echo "Setting joborun config..."
cp ../config .config
make olddefconfig
# diff -u ../config .config || :
make -s kernelrelease > version
echo "Prepared $pkgbase version $(<version)"
}
build() {
cd $_srcname
make all
}
## _make htmldocs
_package() {
pkgdesc="The $pkgdesc kernel and modules w/o zstd ipv6"
depends=(coreutils kmod initramfs)
optdepends=('wireless-regdb: to set the correct wireless channels of your country'
'linux-firmware: firmware images needed for some devices')
provides=(KSMBD-MODULE VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE)
replaces=(virtualbox-guest-modules wireguard
virtualbox-guest-modules-arch wireguard-arch)
cd $_srcname
local kernver="$(<version)"
local modulesdir="$pkgdir/usr/lib/modules/$kernver"
echo "Installing boot image..."
# systemd expects to find the kernel here to allow hibernation
# https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
# Used by mkinitcpio to name the kernel
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
echo "Installing modules..."
make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 \
DEPMOD=/doesnt/exist modules_install # Suppress depmod
# remove build and source links
rm "$modulesdir"/{source,build}
}
_package-headers() {
pkgdesc="Headers and scripts for building modules for the $pkgdesc kernel"
depends=(pahole)
cd $_srcname
local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
echo "Installing build files..."
install -Dt "$builddir" -m644 .config Makefile Module.symvers System.map \
localversion.* version vmlinux
install -Dt "$builddir/kernel" -m644 kernel/Makefile
install -Dt "$builddir/arch/x86" -m644 arch/x86/Makefile
cp -t "$builddir" -a scripts
# required when STACK_VALIDATION is enabled
# add objtool for external module building and enabled VALIDATION_STACK option
install -Dt "$builddir/tools/objtool" tools/objtool/objtool
# add xfs and shmem for aufs building
mkdir -p "$builddir"/{fs/xfs,mm}
# required when DEBUG_INFO_BTF_MODULES is enabled
install -Dt "$builddir/tools/bpf/resolve_btfids" tools/bpf/resolve_btfids/resolve_btfids
echo "Installing headers..."
cp -t "$builddir" -a include
cp -t "$builddir/arch/x86" -a arch/x86/include
install -Dt "$builddir/arch/x86/kernel" -m644 arch/x86/kernel/asm-offsets.s
install -Dt "$builddir/drivers/md" -m644 drivers/md/*.h
install -Dt "$builddir/net/mac80211" -m644 net/mac80211/*.h
# https://bugs.archlinux.org/task/13146
install -Dt "$builddir/drivers/media/i2c" -m644 drivers/media/i2c/msp3400-driver.h
# https://bugs.archlinux.org/task/20402
install -Dt "$builddir/drivers/media/usb/dvb-usb" -m644 drivers/media/usb/dvb-usb/*.h
install -Dt "$builddir/drivers/media/dvb-frontends" -m644 drivers/media/dvb-frontends/*.h
install -Dt "$builddir/drivers/media/tuners" -m644 drivers/media/tuners/*.h
# https://bugs.archlinux.org/task/71392
install -Dt "$builddir/drivers/iio/common/hid-sensors" -m644 drivers/iio/common/hid-sensors/*.h
echo "Installing KConfig files..."
find . -name 'Kconfig*' -exec install -Dm644 {} "$builddir/{}" \;
echo "Removing unneeded architectures..."
local arch
for arch in "$builddir"/arch/*/; do
[[ $arch = */x86/ ]] && continue
echo "Removing $(basename "$arch")"
rm -r "$arch"
done
echo "Removing documentation..."
rm -r "$builddir/Documentation"
echo "Removing broken symlinks..."
find -L "$builddir" -type l -printf 'Removing %P\n' -delete
echo "Removing loose objects..."
find "$builddir" -type f -name '*.o' -printf 'Removing %P\n' -delete
echo "Stripping build tools..."
local file
while read -rd '' file; do
case "$(file -Sib "$file")" in
application/x-sharedlib\;*) # Libraries (.so)
strip -v $STRIP_SHARED "$file" ;;
application/x-archive\;*) # Libraries (.a)
strip -v $STRIP_STATIC "$file" ;;
application/x-executable\;*) # Binaries
strip -v $STRIP_BINARIES "$file" ;;
application/x-pie-executable\;*) # Relocatable binaries
strip -v $STRIP_SHARED "$file" ;;
esac
done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
echo "Stripping vmlinux..."
strip -v $STRIP_STATIC "$builddir/vmlinux"
echo "Adding symlink..."
mkdir -p "$pkgdir/usr/src"
ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"
}
#_package-docs() {
# pkgdesc="Documentation for the $pkgdesc kernel"
#
# cd $_srcname
# local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
#
# echo "Installing documentation..."
# local src dst
# while read -rd '' src; do
# dst="${src#Documentation/}"
# dst="$builddir/Documentation/${dst#output/}"
# install -Dm644 "$src" "$dst"
# done < <(find Documentation -name '.*' -prune -o ! -type d -print0)
#
# echo "Adding symlink..."
# mkdir -p "$pkgdir/usr/share/doc"
# ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"
#}
pkgname=("$pkgbase" "$pkgbase-headers") # "$pkgbase-docs")
for _p in "${pkgname[@]}"; do
eval "package_$_p() {
$(declare -f "_package${_p#$pkgbase}")
_package${_p#$pkgbase}
}"
done
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=(GPL2)
validpgpkeys=(ABAF11C65A2970B130ABE3C479BE3E4300411886 # Linus Torvalds
647F28654894E3BD457199BE38DBBDC86092693E) # Greg Kroah-Hartman
# https://cdn.kernel.org/pub/linux/kernel/v5.x/sha256sums.asc --> sha256sums
# sha256sums:17f85ea79ff2bcd2a577be9d8090e70573a671eaf1d35d897e739ce0603d0698 linux-5.15.154.tar.xz
sha256sums=(17f85ea79ff2bcd2a577be9d8090e70573a671eaf1d35d897e739ce0603d0698 # linux-5.15.154.tar.xz
7475b6d9cd63f79358aae178e522862ecc9b363a54de80f1e2d20ae1c17fdf6f # linux-5.15.154.tar.sign
f25852ccc9eb9c135c50a66835438223ac71abe2e2ef86d7e0667b4fd9f757f2 # config
3b5cfc9ca9cf778ea2c4b619b933cda26519969df2d764b5a687f63cf59974cd # 0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
8357f000b2b622e73dcfd41c2bad42b5e99fffe8f7ee64f774aa771f86cef43c # 0003-iommu-intel-do-deep-dma-unmapping-to-avoid-kernel-fl.patch
5c1ee81fdd5818442af6081de987f9c1a9ce3c8d183566b3dfc19a8433aa3dde # 0004-Bluetooth-btintel-Fix-bdaddress-comparison-with-garb.patch
067e8995fcd6f6ed25e0253e9374c0e179a000c154da3e59ce62634945ac5be9 # 0005-lg-laptop-Recognize-more-models.patch
856230cfbdc2bb53a4920dfbcb6fb2d58427b7b184e5f94e21f08011d0a2fcc6 # i915-vga-arbiter.patch
8a97f52da3bdad208565be481d08dbf779a8ac6feb8ce2de750275a9fb745c7b) # sha256sums
## b2b70e8d456304c8f5d1b5bb3288d3ee572ee8de95567c88badc84578c9c6ea3 linux-5.15.154-01-x86_64.pkg.tar.lz
## b0970dce984e63e83b574c8599b05ce5479fff1d3838b040d500424d0efe76ed linux-headers-5.15.154-01-x86_64.pkg.tar.lz