jobcore/lzip/PKGBUILD-arch

29 lines
897 B
Plaintext

# Maintainer: Jiachen Yang <farseerfc@gmail.com>
# Contributor: apophys <admin AT kubikmilan DOT sk>
# Contributor: Christoph Zeiler <archNOSPAM_at_moonblade.dot.org>
# Contributor: Renzo Carbonara <gnuk0001/gmail.com>
pkgname=lzip
pkgver=1.24.1
pkgrel=1
pkgdesc="A lossless file compressor based on the LZMA algorithm"
arch=('x86_64')
url="https://www.nongnu.org/lzip/lzip.html"
license=('GPL3')
depends=('gcc-libs')
source=("https://download.savannah.gnu.org/releases/$pkgname/$pkgname-$pkgver.tar.gz"{,.sig})
sha256sums=('30c9cb6a0605f479c496c376eb629a48b0a1696d167e3c1e090c5defa481b162'
'SKIP')
validpgpkeys=('1D41C14B272A2219A739FA4F8FE99503132D7742') # Antonio Diaz Diaz <antonio@gnu.org>
build() {
cd $pkgname-$pkgver
./configure --prefix=/usr CXXFLAGS="$CXXFLAGS" LDFLAGS="$LDFLAGS"
make
}
package() {
cd $pkgname-$pkgver
make DESTDIR="$pkgdir" install{,-man}
}