jobcore/mpfr/PKGBUILD

75 lines
2.1 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcore/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=mpfr
_pkgver=4.2.1
_patchver=0
if (( _patchver == 0 )); then
pkgver=$_pkgver
else
pkgver=$_pkgver.p$_patchver
fi
pkgrel=02
pkgdesc='Multiple-precision floating-point library'
url='https://www.mpfr.org/'
depends=('glibc' 'gmp')
makedepends=('autoconf-archive' 'automake')
#options=(debug) ### uncomment here for debug pkg
provides=(libmpfr.so)
# NOTE: download potentially existing patches from upstream:
# `curl patches.diff -o https://www.mpfr.org/mpfr-${_pkgver}/allpatches`
source=(https://ftp.gnu.org/gnu/$pkgname/$pkgname-$_pkgver.tar.xz{,.sig}
patches.diff::https://www.mpfr.org/mpfr-${_pkgver}/allpatches)
## options=(debug) ## uncomment this to produce the debug pkg
prepare() {
cd $pkgname-${_pkgver}
for src in "${source[@]}"; do
[[ "$src" == *.diff ]] || [[ "$src" == *.patch ]] || continue
printf "Applying patch %s...\n" "$src"
patch -Np1 -i "../$src"
done
autoreconf -fiv
}
build() {
cd $pkgname-${_pkgver}
./configure --prefix=/usr \
--enable-thread-safe \
--enable-shared
make
}
check() {
cd $pkgname-${_pkgver}
make check
make check-exported-symbols
}
package() {
cd $pkgname-${_pkgver}
make DESTDIR="$pkgdir" install
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=('GPL3' 'LGPL3')
validpgpkeys=('07F3DBBECC1A39605078094D980C197698C3739D'
'A534BE3F83E241D918280AEB5831D11A0D4DB02A') # Vincent Lefevre <vincent@vinc17.net>
sha256sums=(277807353a6726978996945af13e52829e3abd7a9a5b7fb2793894e18f1fcbb2 # mpfr-4.2.1.tar.xz
9fc30cf79beae3e4b06520611ad47dbc69cc5953b06f79cb228334066ecf4e97 # mpfr-4.2.1.tar.xz.sig
a9099cee74188d5f522b7b3fca0097196c6dd38126f8f042d233010cbf92e8d0) # patches.diff
## 0359d0275a4735fa8a9c796c44f74d7401ba003255025f927a18e1c1863de62e mpfr-4.2.1-02-x86_64.pkg.tar.lz