jobcore/nettle/PKGBUILD

48 lines
1.3 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcore/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=nettle
pkgver=3.9.1
pkgrel=01
pkgdesc="A low-level cryptographic library"
url="https://www.lysator.liu.se/~nisse/nettle"
depends=('gmp' 'glibc')
provides=('libnettle.so' 'libhogweed.so')
checkdepends=('valgrind')
#options=('debug') ### Uncomment this line to have the debug package produced.
source=(https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz{,.sig})
build() {
cd $pkgname-$pkgver
./configure --prefix=/usr \
--disable-static
make
}
check() {
cd $pkgname-$pkgver
make -k check
}
package() {
cd $pkgname-$pkgver
make DESTDIR="$pkgdir/" install
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=('GPL2')
validpgpkeys=('343C2FF0FBEE5EC2EDBEF399F3599FF828C67298') # Niels Möller <nisse@lysator.liu.se>
sha256sums=(ccfeff981b0ca71bbd6fbcb054f407c60ffb644389a5be80d6716d5b550c6ce3 # nettle-3.9.1.tar.gz
793b2f165f3527d0ae54d36f3c042908204bd8871598cdcd7c0ff2d3725eb8f5) # nettle-3.9.1.tar.gz.sig
## 564b4a39df5e9c67407d038c61f6dea7b4d0ad2361962f922ff297fc4f4852a9 nettle-3.9.1-01-x86_64.pkg.tar.lz