jobcore/openresolv/PKGBUILD

59 lines
1.5 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcore/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=openresolv
pkgver=3.13.2
pkgrel=02
pkgdesc="resolv.conf management framework (resolvconf) w/o systemd"
url="https://roy.marples.name/projects/openresolv"
backup=(etc/resolvconf.conf)
provides=(resolvconf)
conflicts=(resolvconf)
depends=(bash)
makedepends=()
#source=("https://roy.marples.name/downloads/openresolv/${pkgname}-${pkgver}.tar.xz"
_commit=867a412d63a28d2c4978e02fc44fb8013f46d356 # tags/v3.13.2^0
source=("git+https://github.com/NetworkConfiguration/openresolv#commit=$_commit")
pkgver() {
cd $pkgname
git describe --tags | sed 's/^v//;s/[^-]*-g/r&/;s/-/+/g'
}
prepare() {
cd $pkgname
# patch -Np1 -i ../fs33801.patch
}
build() {
cd $pkgname
./configure \
--prefix=/usr \
--sysconfdir=/etc \
--libexecdir=/usr/lib/resolvconf \
--sbindir=/usr/bin
make
}
package() {
cd $pkgname
make DESTDIR="$pkgdir" install
install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 LICENSE
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=('custom:BSD')
sha256sums=(SKIP)
## 37708f1b8800cba43eecc22b9945bc30ea7f99d293164c09e3affde32de83c50 openresolv-3.13.2-02-x86_64.pkg.tar.lz
37708f1b8800cba43eecc22b9945bc30ea7f99d293164c09e3affde32de83c50 openresolv-3.13.2-02-x86_64.pkg.tar.lz