jobcore/opentmpfiles/PKGBUILD-oba

66 lines
1.8 KiB
Plaintext

# Obarun : 66 init/supervisor
# Maintainer : Eric Vidal <eric@obarun.org>
# Maintainer : Jean-Michel T.Dydak <jean-michel@obarun.org>
# Obarun PkgSrc : url="https://git.obarun.org/pkg/obextra/opentmpfiles"
#----------------
# Website : https://git.obarun.org/obdev/opentmpfiles.git
#----------------------------------------------------------------------------
#--DESCRIPTION---------------------------------------------------------------
pkgname=(opentmpfiles)
pkgdesc="Script written in pure POSIX sh to parse and apply tmpfiles.d style file coming from systemd"
pkgver=0.3.1
pkgrel=3
url="https://git.obarun.org/obdev/opentmpfiles.git"
track="tag"
target="v${pkgver}"
source=(
"${pkgname}::git+${url}#${track}=${target}"
"opentmpfiles.hook"
)
#--BUILD CONFIGURATION-------------------------------------------------------
makedepends=('git')
#--BUILD CONTROL-------------------------------------------------------------
path=(--bindir=/usr/bin)
#--BUILD---------------------------------------------------------------------
build() {
cd $pkgname
./configure "${path[@]}"
}
#--PACKAGE-------------------------------------------------------------------
package() {
cd $pkgname
make DESTDIR="${pkgdir}" install
install -Dm 0644 ${srcdir}/opentmpfiles.hook ${pkgdir}/usr/share/libalpm/hooks/opentmpfiles.hook
install -Dm 0644 LICENSE ${pkgdir}/usr/share/${pkgname}/LICENSE
}
#--INSTALL CONFIGURATION-----------------------------------------------------
arch=('x86_64')
#--SECURITY AND LICENCE------------------------------------------------------
sha512sums=('SKIP'
'27ed59dec6441bc8e462d7f13c8257c97077f6f175048def698fe54f29b4ba3b9ea6833ce4b970431cff2d07031580337957153d5c018ab8f69718bdda357688')
license=('BSD 2-Clause')