jobcore/pciutils/PKGBUILD

56 lines
2.4 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcore/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=pciutils
pkgver=3.12.0
pkgrel=01
pkgdesc="PCI bus configuration space access library and tools"
url="https://mj.ucw.cz/sw/pciutils/"
url2="https://www.kernel.org/pub/software/utils/pciutils/"
depends=('glibc' 'hwdata' 'kmod')
#makedepends=('git')
optdepends=('which: for update-pciids'
'grep: for update-pciids'
'curl: for update-pciids')
source=(#ftp://ftp.kernel.org/pub/software/utils/${pkgname}/${pkgname}-${pkgver}.tar.bz2)
# https://mirrors.edge.kernel.org/pub/software/utils/${pkgname}/${pkgname}-${pkgver}.tar.{xz,sign})
# https://mirrors.edge.kernel.org/pub/software/utils/${pkgname}/${pkgname}-${pkgver}.tar.xz)
https://mj.ucw.cz/download/linux/pci/${pkgname}-${pkgver}.tar.gz{,.sign})
#git+https://github.com/pciutils/pciutils.git#tag=v$pkgver?signed)
build() {
cd $pkgname-$pkgver
make OPT="${CFLAGS} -fPIC -DPIC" ZLIB=no SHARED=no PREFIX=/usr SHAREDIR=/usr/share/hwdata MANDIR=/usr/share/man SBINDIR=/usr/bin lib/libpci.a
cp lib/libpci.a "${srcdir}/"
make clean
make OPT="${CFLAGS}" ZLIB=no SHARED=yes PREFIX=/usr SBINDIR=/usr/bin SHAREDIR=/usr/share/hwdata MANDIR=/usr/share/man all
}
package() {
cd $pkgname-$pkgver
make SHARED=yes PREFIX=/usr SBINDIR=/usr/bin SHAREDIR=/usr/share/hwdata MANDIR=/usr/share/man DESTDIR="${pkgdir}" install install-lib
rm -rf "$pkgdir"/usr/share/hwdata
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=('GPL2')
validpgpkeys=(C466A56CADA981F4297D20C31F3D0761D9B65F0B # Martin Mares <mj@ucw.cz>
5558F9399CD7836850553C6EC28E7847ED70F82D) # Martin Mares <mj@ucw.cz>
sha256sums=(827a641d2016a15f0b959804daa5a05f055d0f91d58a70d32ac41ce7ef94164e # pciutils-3.12.0.tar.gz
91caa8ed25dda0cef3e9e0a273c347a33333dd00ff134443c6255e89b5c953ae) # pciutils-3.12.0.tar.gz.sign
# f185d116d5ff99b797497efce8f19f1ee8ccc5a668b97a159e3d13472f674154 pciutils-3.12.0.tar.xz
# 73780101e45316efd3d2fa962e4816919b35dcd21ae23b1e5e30c21163d1f8de) # pciutils-3.12.0.tar.sign
## 1fa005bd47ec73275ed264dd88970d3ef8993fd88d45a541920d9bb6836f6233 pciutils-3.12.0-01-x86_64.pkg.tar.lz