jobcore/pinentry/PKGBUILD

78 lines
2.7 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcore/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=pinentry
pkgver=1.3.0
pkgrel=01 ## useless rebuild due to Kwayland to 5 rebadging - waste of a core repository
### to be affected by KDE-plaZma crap --- WASTE!!!
pkgdesc='Collection of simple PIN or passphrase entry dialogs which utilize the Assuan protocol'
url='https://gnupg.org/related_software/pinentry/'
depends=(
'glibc' 'ncurses' 'libassuan' 'libsecret' 'glib2'
libsecret-1.so libncursesw.so libassuan.so libglib-2.0.so)
makedepends=('gtk2' 'qt5-base' 'qt6-base' 'gcr' 'qt5-x11extras')
optdepends=(
'gtk2: gtk2 backend'
'qt5-base: qt5 backend'
'qt6-base: qt6 backend'
'qt5-x11extras: qt backend'
'gcr: gnome3 backend'
)
backup=('etc/pinentry/preexec')
source=("https://www.gnupg.org/ftp/gcrypt/${pkgname}/${pkgname}-${pkgver}.tar.bz2"{,.sig}
'pinentry'
'preexec')
## --enable-pinentry-qt becomes qt6 base --enable-pinentry-qt5 needs to be specific
## Arch seems to just worry about plasma qt6 based applications
build() {
cd "${pkgname}-${pkgver}"
./configure \
--prefix=/usr \
--enable-pinentry-tty \
--enable-pinentry-curses \
--enable-fallback-curses \
--enable-pinentry-emacs \
--enable-pinentry-gtk2 \
--enable-pinentry-gnome3 \
--enable-pinentry-qt5 \
--enable-pinentry-qt \
--enable-libsecret \
make
}
package() {
cd "${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
install -Dm 755 ../pinentry -t "${pkgdir}/usr/bin"
install -Dm 755 ../preexec -t "${pkgdir}/etc/pinentry"
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=('GPL')
validpgpkeys=(D8692123C4065DEA5E0F3AB5249B39D24F25E3B6 # Werner Koch (dist sig)
6DAA6E64A76D2840571B4902528897B826403ADA # Werner Koch (dist signing 2020)
AC8E115BF73E2D8D47FA9908E98E9B2D19C6C8BD) # Niibe Yutaka (GnuPG Release Key)
sha256sums=(9b3cd5226e7597f2fded399a3bc659923351536559e9db0826981bca316494de # pinentry-1.3.0.tar.bz2
## 457a185e5a85238fb945a955dc6352ab962dc8b48720b62fc9fa48c7540a4067 # pinentry-1.2.1.tar.bz2
3d4753e5262a36651dee14ea4e0e9461126d93fddd05f2da2ef95be4cb3ce1f0 # pinentry-1.3.0.tar.bz2.sig
## 22b5493faad409a5f4b25d07d74d228c67631110258e10094bd954b16e9e55e2 # pinentry-1.2.1.tar.bz2.sig
af7c27139b20a7f1b9a227f3663abb21bb2b954523352b7844da27db1b0c1c86 # pinentry
f428f08d77f1f7830eadb8435af282a833fc13d8b623b122eefd9d3b628bef90) # preexec
## 708a826054699bbe421330a8243aa2c4ab8499cfe8bc77bc8dcd75aaa8c642fc pinentry-1.3.0-01-x86_64.pkg.tar.lz