jobcore/python/PKGBUILD

156 lines
6.0 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcore/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
shopt -s extglob
pkgbase=python
pkgname=(python python-tests)
pkgver=3.12.3
pkgrel=01
_pybasever=${pkgver%.*}
pkgdesc="The Python programming language - ipv6 disabled "
url="https://www.python.org/"
depends=('bzip2' 'expat' 'gdbm' 'libffi' 'libnsl' 'libxcrypt' 'mpdecimal' 'openssl' 'zlib' 'tzdata')
makedepends=('tk' 'sqlite' 'bluez-libs' 'llvm' 'gdb' 'xorg-server-xvfb' 'ttf-font')
#options=('debug') ## uncomment this to have the debug pkg produced
source=("https://www.python.org/ftp/python/${pkgver%rc*}/Python-${pkgver}.tar.xz"{,.asc}
EXTERNALLY-MANAGED)
# https://github.com/python/cpython/commit/178a238f25ab8aff7689d7a09d66dc1583ecd6cb.patch)
prepare() {
cd Python-${pkgver}
# FS#23997
sed -i -e "s|^#.* /usr/local/bin/python|#!/usr/bin/python|" Lib/cgi.py
# Ensure that we are using the system copy of various libraries (expat, libffi, and libmpdec),
# rather than copies shipped in the tarball
rm -r Modules/expat
# rm -r Modules/_ctypes/{darwin,libffi}*
rm -r Modules/_decimal/libmpdec
}
build() {
cd Python-${pkgver}
# PGO should be done with -O3
CFLAGS="${CFLAGS/-O2/-O3} -ffat-lto-objects"
# Disable bundled pip & setuptools
./configure --prefix=/usr \
--enable-shared \
--with-computed-gotos \
--enable-optimizations \
--with-lto \
--disable-ipv6 \
--with-system-expat \
--with-dbmliborder=gdbm:ndbm \
--with-system-libmpdec \
--enable-loadable-sqlite-extensions \
--without-ensurepip \
--with-tzpath=/usr/share/zoneinfo
# Obtain next free server number for xvfb-run; this even works in a chroot environment.
export servernum=99
while ! xvfb-run -a -n "$servernum" /bin/true 2>/dev/null; do servernum=$((servernum+1)); done
LC_CTYPE=en_US.UTF-8 xvfb-run -s "-screen 0 1920x1080x16 -ac +extension GLX" -a -n "$servernum" make EXTRA_CFLAGS="$CFLAGS"
}
check() {
# test_tk: test_askcolor tkinter.test.test_tkinter.test_colorchooser.DefaultRootTest hangs
# test_pyexpat: our `debug` implementation rewrites source location, which breaks the build-time
# only test test.test_pyexpat.HandlerExceptionTest as it cannot find source file in
# the to-be-installed debug package
# test_socket: https://github.com/python/cpython/issues/79428
# test_unittest: https://github.com/python/cpython/issues/108927
# test_tkk: AssertionError: Tuples differ: (0,) != ('0',)
cd Python-${pkgver}
# Obtain next free server number for xvfb-run; this even works in a chroot environment.
export servernum=99
while ! xvfb-run -a -n "$servernum" /bin/true 2>/dev/null; do servernum=$((servernum+1)); done
LD_LIBRARY_PATH="${srcdir}/Python-${pkgver}":${LD_LIBRARY_PATH} \
LC_CTYPE=en_US.UTF-8 xvfb-run -s "-screen 0 1920x1080x16 -ac +extension GLX" -a -n "$servernum" \
"${srcdir}/Python-${pkgver}/python" -m test.regrtest -v -uall -x test_tk -x \
test_ttk -x test_ttk.test_widgets -x test_tkinter -x test_pyexpat -x test_socket -x test_unittest
}
package_python() {
optdepends=('python-setuptools'
'python-pip'
'python-pipx: for installing Python software not packaged on Arch Linux'
'sqlite: for a default database integration'
'xz: for lzma'
'tk: for tkinter')
provides=('python3' 'python-externally-managed')
replaces=('python3' 'python-externally-managed')
cd Python-${pkgver}
# Hack to avoid building again
sed -i 's/^all:.*$/all: build_all/' Makefile
# PGO should be done with -O3
CFLAGS="${CFLAGS/-O2/-O3}"
make DESTDIR="${pkgdir}" EXTRA_CFLAGS="$CFLAGS" install
# Why are these not done by default...
ln -s python3 "${pkgdir}"/usr/bin/python
ln -s python3-config "${pkgdir}"/usr/bin/python-config
ln -s idle3 "${pkgdir}"/usr/bin/idle
ln -s pydoc3 "${pkgdir}"/usr/bin/pydoc
ln -s python${_pybasever}.1 "${pkgdir}"/usr/share/man/man1/python.1
# some useful "stuff" FS#46146
install -dm755 "${pkgdir}"/usr/lib/python${_pybasever}/Tools/{i18n,scripts}
install -m755 Tools/i18n/{msgfmt,pygettext}.py "${pkgdir}"/usr/lib/python${_pybasever}/Tools/i18n/
install -m755 Tools/scripts/{README,*py} "${pkgdir}"/usr/lib/python${_pybasever}/Tools/scripts/
# PEP668
install -Dm644 "$srcdir"/EXTERNALLY-MANAGED -t "${pkgdir}/usr/lib/python${_pybasever}/"
# Split tests
cd "$pkgdir"/usr/lib/python*/
rm -r {test,idlelib/idle_test}
}
package_python-tests() {
pkgdesc="Regression tests packages for Python"
depends=('python')
cd Python-${pkgver}
make DESTDIR="${pkgdir}" EXTRA_CFLAGS="$CFLAGS" libinstall
cd "$pkgdir"/usr/lib/python*/
rm -r !(test)
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=('PSF-2.0')
validpgpkeys=('0D96DF4D4110E5C43FBFB17F2D347EA6AA65421D' # Ned Deily (Python release signing key) <nad@python.org>
'E3FF2839C048B25C084DEBE9B26995E310250568' # Łukasz Langa (GPG langa.pl) <lukasz@langa.pl>
'A035C8C19219BA821ECEA86B64E628F8D684696D' # Pablo Galindo Salgado <pablogsal@gmail.com>
'7169605F62C751356D054A26A821E680E5FA6305') # Thomas Wouters <thomas@xs4all.nl>
sha256sums=(56bfef1fdfc1221ce6720e43a661e3eb41785dd914ce99698d8c7896af4bdaa1 # Python-3.12.3.tar.xz
45cd37115adfab87341018fc7c8835da23d06925330a4c5f2dcf4876c484acaa # Python-3.12.3.tar.xz.asc
c07b94bf7dcbe7be5ba0cee29971a005a5be65002cbfb59c5a8f661fa92aa82f) # EXTERNALLY-MANAGED
## b91860d994044659370c22709c71656e8e9609b7679b0f9bfbe072aa007b659e python-3.12.3-01-x86_64.pkg.tar.lz
## 7cff905a68337dcc2712f2300b3dffcc56c89b01c187b0a12b9d9c523139919e python-tests-3.12.3-01-x86_64.pkg.tar.lz